# CVE-2026-42238: Unauthenticated Remote Code Execution via Backup Restore in nginx-ui

> Unauthenticated attackers can achieve remote code execution by uploading a malicious backup archive during the initial startup window of nginx-ui.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 5 May 2026
- **Also known as:** GHSA-4pvg-prr3-9cxr, GO-2026-5129

## What is CVE-2026-42238?

CVE-2026-42238 is a critical code injection vulnerability in 0xJacky nginx-ui, published on 4 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.8, nginx-ui exposes a backup restore endpoint (POST /api/restore) that is completely unauthenticated during the first 10 minutes after process startup on any fresh installation. An unauthenticated remote attacker can upload a crafted backup archive that overwrites the application's configuration file (app.ini) and SQLite database. Because the attacker controls the restored app.ini, they can inject an arbitrary OS command into the TestConfigCmd setting. After the application automatically restarts to apply the restored config, a single follow-up request triggers that command as the user running nginx-ui — typically root in Docker deployments. This issue has been patched in version 2.3.8.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-42238?

3 open source packages ship an affected version, including github.com/0xJacky/nginx-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/0xJacky/nginx-ui` | Go | All versions | None |
| `github.com/0xJacky/nginx-ui` | Go | All versions | 2.3.8 |
| `github.com/0xJacky/nginx-ui` | Go | All versions | 2.3.8 |

Products: Nginxui Nginx Ui.

## How do I fix CVE-2026-42238?

Upgrade github.com/0xJacky/nginx-ui to 2.3.8 or later.

## Is CVE-2026-42238 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42238 exists.

## Other vulnerabilities in 0xJacky nginx-ui

- [CVE-2026-33032](https://insights.sbomify.com/CVE-2026-33032/): Nginx UI: Unauthenticated MCP Endpoint Allows Remote Nginx Takeover (critical 9.8)
- [CVE-2026-27944](https://insights.sbomify.com/CVE-2026-27944/): Nginx UI: Unauthenticated Backup Download with Encryption Key Disclosure (critical 9.8)
- [CVE-2024-23827](https://insights.sbomify.com/CVE-2024-23827/): Nginx-UI arbitrary file write through the Import Certificate feature (critical 9.8)
- [CVE-2026-107806](https://insights.sbomify.com/CVE-2026-107806/): Nginx UI: Authenticated Remote Code Execution via Backup Restore App Config Overwrite (critical 9.4)
- [CVE-2026-33026](https://insights.sbomify.com/CVE-2026-33026/): nginx-ui Backup Restore Allows Tampering with Encrypted Backups (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42238 and fix it if it is affected.

What it is: CVE-2026-42238 is a critical code injection vulnerability in 0xJacky nginx-ui, published on 4 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42238 exists.

Affected packages and fixed versions:
- github.com/0xJacky/nginx-ui (Go): affected all versions; no fix listed
- github.com/0xJacky/nginx-ui (Go): affected all versions; fixed in 2.3.8
- github.com/0xJacky/nginx-ui (Go): affected all versions; fixed in 2.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42238/ (Markdown: https://insights.sbomify.com/CVE-2026-42238/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42238
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42238
- OSV: https://osv.dev/vulnerability/CVE-2026-42238

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42238/
Summaries are generated and may contain mistakes; the official description above is the record.
