# CVE-2026-42241: ParquetSharp: Possible Stack Overflow When Reading a ParquetFile with Large Decimal Type Width

> Attackers can cause a stack overflow and service crash by providing a Parquet file with an excessively large decimal column width.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-rrjr-v56m-ww88

## What is CVE-2026-42241?

CVE-2026-42241 is a medium-severity denial of service vulnerability in G-Research ParquetSharp, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ParquetSharp is a .NET library for reading and writing Apache Parquet files. From version 18.1.0 to before version 23.0.0.1, DecimalConverter.ReadDecimal makes a stackalloc using what might be an attacker-supplied value. If an attacker declares a decimal column with some unreasonable width, this could lead to a stack overflow. In a service environment, this would potentially take down a service. This affects applications using ParquetSharp to read untrusted Parquet files in a network service. This issue has been patched in version 23.0.0.1.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-42241?

2 open source packages ship an affected version, including ParquetSharp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ParquetSharp` | NuGet | From 18.1.0 | 23.0.0.1 |
| `ParquetSharp` | NuGet | From 18.1.0 | 23.0.0.1 |

## How do I fix CVE-2026-42241?

Upgrade ParquetSharp to 23.0.0.1 or later.

## Is CVE-2026-42241 being exploited?

There is no known exploitation of CVE-2026-42241 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42241 and fix it if it is affected.

What it is: CVE-2026-42241 is a medium-severity denial of service vulnerability in G-Research ParquetSharp, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42241 in the wild and no public exploit code.

Affected packages and fixed versions:
- ParquetSharp (NuGet): affected from 18.1.0; fixed in 23.0.0.1
- ParquetSharp (NuGet): affected from 18.1.0; fixed in 23.0.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42241/ (Markdown: https://insights.sbomify.com/CVE-2026-42241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42241
- OSV: https://osv.dev/vulnerability/CVE-2026-42241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42241/
Summaries are generated and may contain mistakes; the official description above is the record.
