# CVE-2026-42246: net-imap vulnerable to STARTTLS stripping via invalid response timing

> A man-in-the-middle attacker can bypass TLS encryption in the Ruby net-imap library, exposing email data to interception.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 May 2026
- **Updated:** 24 Aug 2026
- **Also known as:** ALPINE-CVE-2026-42246, BELL-CVE-2026-42246, CLEANSTART-2026-FA36805, CLEANSTART-2026-MW08049, CLSA-2026-1783525446, DEBIAN-CVE-2026-42246, ECHO-eef9-a5b3-0486, GHSA-vcgp-9326-pqcp, MINI-26jr-fhcm-gccr, MINI-2c6w-pfmf-85wp, MINI-3h68-2cm2-wgch, MINI-7r98-q4pj-rchq, MINI-8pqj-4hh8-745v, MINI-8xqq-cxcm-g8rr, MINI-c59h-9gxp-67vp, MINI-c6ff-pq6q-mhvf, MINI-fqvm-7vhq-4rjh, MINI-gxcw-m398-7r43, MINI-hc4c-3prc-92pc, MINI-hw86-3285-6jh8, MINI-p4pw-q4v5-m5xx, MINI-phm7-xjqf-292c, MINI-v2pf-fphg-vw4p, MINI-w2v5-qm7x-592x, MINI-w7g8-9cp6-vcgh, ROOT-APP-RUBY-CVE-2026-42246

## What is CVE-2026-42246?

CVE-2026-42246 is a high-severity vulnerability in ruby net-imap, published on 9 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.3.10, 0.4.24, 0.5.14, and 0.6.4, a man-in-the-middle attacker can cause Net::IMAP#starttls to return "successfully", without starting TLS. This issue has been patched in versions 0.3.10, 0.4.24, 0.5.14, and 0.6.4.

Weakness: CWE-325 (Missing Cryptographic Step), CWE-841 (Improper Enforcement of Behavioral Workflow), CWE-754 (Improper Check for Unusual or Exceptional Conditions), CWE-636 (Not Failing Securely), CWE-393 (Return of Wrong Status Code), CWE-392 (Missing Report of Error Condition)

## Which versions are affected by CVE-2026-42246?

8 open source packages ship an affected version, including net-imap. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net-imap` | RubyGems | All versions | 0.3.10 |
| `net-imap` | RubyGems | All versions | 0.3.10 |
| `net-imap` | RubyGems | From 0.4.0 | 0.4.24 |
| `net-imap` | RubyGems | From 0.4.0 | 0.4.24 |
| `net-imap` | RubyGems | From 0.5.0 | 0.5.14 |
| `net-imap` | RubyGems | From 0.5.0 | 0.5.14 |
| `net-imap` | RubyGems | From 0.6.0 | 0.6.4 |
| `net-imap` | RubyGems | From 0.6.0 | 0.6.4 |

Products: Ruby-Lang Net\.

## How do I fix CVE-2026-42246?

Upgrade net-imap to a fixed version for your release line: 0.3.10, 0.4.24, 0.5.14 or 0.6.4.

## Is CVE-2026-42246 being exploited?

There is no known exploitation of CVE-2026-42246 in the wild and no public exploit code.

## Other vulnerabilities in ruby net-imap

- [CVE-2026-42256](https://insights.sbomify.com/CVE-2026-42256/): net-imap: Denial of service via high iteration count for `SCRAM-*` authentication (medium 6.0)
- [CVE-2025-43857](https://insights.sbomify.com/CVE-2025-43857/): net-imap rubygem vulnerable to possible DoS by memory exhaustion (medium 6.0)
- [CVE-2026-42257](https://insights.sbomify.com/CVE-2026-42257/): net-imap: Command Injection via "raw" arguments to multiple commands (medium 5.8)
- [CVE-2026-42258](https://insights.sbomify.com/CVE-2026-42258/): net-imap: Command Injection via unvalidated Symbol inputs (medium 5.8)
- [CVE-2026-42245](https://insights.sbomify.com/CVE-2026-42245/): net-imap: Quadratic complexity when reading response literals (low 2.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42246 and fix it if it is affected.

What it is: CVE-2026-42246 is a high-severity vulnerability in ruby net-imap, published on 9 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42246 in the wild and no public exploit code.

Affected packages and fixed versions:
- net-imap (RubyGems): affected all versions; fixed in 0.3.10
- net-imap (RubyGems): affected all versions; fixed in 0.3.10
- net-imap (RubyGems): affected from 0.4.0; fixed in 0.4.24
- net-imap (RubyGems): affected from 0.4.0; fixed in 0.4.24
- net-imap (RubyGems): affected from 0.5.0; fixed in 0.5.14
- net-imap (RubyGems): affected from 0.5.0; fixed in 0.5.14
- net-imap (RubyGems): affected from 0.6.0; fixed in 0.6.4
- net-imap (RubyGems): affected from 0.6.0; fixed in 0.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42246/ (Markdown: https://insights.sbomify.com/CVE-2026-42246/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42246
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42246
- OSV: https://osv.dev/vulnerability/CVE-2026-42246

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42246/
Summaries are generated and may contain mistakes; the official description above is the record.
