# CVE-2026-42254: Other in Hickory DNS

> Attackers can poison DNS cache entries across zones, leading to incorrect resolution data for users of the Hickory DNS recursor.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Apr 2026
- **Updated:** 27 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-42254, GHSA-2hfw-w5cw-p4g7, GHSA-83hf-93m4-rgwq, UBUNTU-CVE-2026-42254

## What is CVE-2026-42254?

CVE-2026-42254 is a medium-severity vulnerability in Hickory DNS, published on 26 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hickory DNS hickory-recursor 0.1 through 0.25.2 allows cross-zone poisoning because cached data is not directly associated with a query that triggered a response.

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference)

## Which versions are affected by CVE-2026-42254?

4 open source packages ship an affected version, including hickory-recursor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hickory-recursor` | crates.io | All versions | None |
| `hickory-recursor` | crates.io | All versions | None |
| `hickory-recursor` | crates.io | From 0.24.0 | 0.26.0 |
| `hickory-recursor` | crates.io | From 0.24.0 | 0.26.0 |

## How do I fix CVE-2026-42254?

Upgrade hickory-recursor to 0.26.0 or later.

## Is CVE-2026-42254 being exploited?

There is no known exploitation of CVE-2026-42254 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42254 and fix it if it is affected.

What it is: CVE-2026-42254 is a medium-severity vulnerability in Hickory DNS, published on 26 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42254 in the wild and no public exploit code.

Affected packages and fixed versions:
- hickory-recursor (crates.io): affected all versions; no fix listed
- hickory-recursor (crates.io): affected all versions; no fix listed
- hickory-recursor (crates.io): affected from 0.24.0; fixed in 0.26.0
- hickory-recursor (crates.io): affected from 0.24.0; fixed in 0.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42254/ (Markdown: https://insights.sbomify.com/CVE-2026-42254/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42254
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42254
- OSV: https://osv.dev/vulnerability/CVE-2026-42254

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42254/
Summaries are generated and may contain mistakes; the official description above is the record.
