# CVE-2026-42256: net-imap: Denial of service via high iteration count for `SCRAM-*` authentication

> A malicious IMAP server can cause a denial of service in Ruby clients using SCRAM authentication by sending a high iteration count.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 May 2026
- **Updated:** 11 May 2026
- **Also known as:** ALPINE-CVE-2026-42256, BELL-CVE-2026-42256, CLEANSTART-2026-MC27877, CLEANSTART-2026-MH39201, DEBIAN-CVE-2026-42256, ECHO-0e5e-7c8e-8329, GHSA-87pf-fpwv-p7m7, MINI-2x72-7w9w-v755, MINI-4j7f-7wcp-mhv2, MINI-6p2q-gr4x-vx4h, MINI-87rf-rrcq-pwjm, MINI-8r34-84wm-mp5x, MINI-97qf-jpr2-m7hf, MINI-ch2q-7q5p-m959, MINI-cvpv-cv26-jxx7, MINI-hmv5-2m52-vx4x, MINI-p969-6jr4-66qr, MINI-qgjr-q5xg-ccjp, MINI-qv73-2x32-59hr, MINI-r367-hmg3-fqx7, MINI-vp68-5frx-jcjg, SUSE-SU-2026:3792-1, openSUSE-SU-2026:21225-1

## What is CVE-2026-42256?

CVE-2026-42256 is a medium-severity denial of service vulnerability in ruby net-imap, published on 9 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. From versions 0.4.0 to before 0.4.24, 0.5.0 to before 0.5.14, and 0.6.0 to before 0.6.4, when authenticating a connection with SCRAM-SHA1 or SCRAM-SHA256, a hostile server can perform a computational denial-of-service attack on the client process by sending a big iteration count value. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-1322 (Use of Blocking Code in Single-threaded, Non-blocking Context)

## Which versions are affected by CVE-2026-42256?

6 open source packages ship an affected version, including net-imap. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net-imap` | RubyGems | From 0.4.0 | 0.4.24 |
| `net-imap` | RubyGems | From 0.4.0 | 0.4.24 |
| `net-imap` | RubyGems | From 0.5.0 | 0.5.14 |
| `net-imap` | RubyGems | From 0.5.0 | 0.5.14 |
| `net-imap` | RubyGems | From 0.6.0 | 0.6.4 |
| `net-imap` | RubyGems | From 0.6.0 | 0.6.4 |
| `rmt-server` | SUSE:Linux Enterprise Module for Public Cloud 15 SP7 | All versions | 3.1.0-150700.3.28.1 |
| `rmt-server` | SUSE:Linux Enterprise Module for Server Applications 15 SP7 | All versions | 3.1.0-150700.3.28.1 |
| `rmt-server` | openSUSE:Leap 16.0 | All versions | 3.0.0-160000.1.1 |

Products: Ruby-Lang Net\.

## How do I fix CVE-2026-42256?

Upgrade net-imap to a fixed version for your release line: 0.4.24, 0.5.14 or 0.6.4.

## Is CVE-2026-42256 being exploited?

There is no known exploitation of CVE-2026-42256 in the wild and no public exploit code.

## Other vulnerabilities in ruby net-imap

- [CVE-2026-42246](https://insights.sbomify.com/CVE-2026-42246/): net-imap vulnerable to STARTTLS stripping via invalid response timing (high 7.6)
- [CVE-2025-43857](https://insights.sbomify.com/CVE-2025-43857/): net-imap rubygem vulnerable to possible DoS by memory exhaustion (medium 6.0)
- [CVE-2026-42257](https://insights.sbomify.com/CVE-2026-42257/): net-imap: Command Injection via "raw" arguments to multiple commands (medium 5.8)
- [CVE-2026-42258](https://insights.sbomify.com/CVE-2026-42258/): net-imap: Command Injection via unvalidated Symbol inputs (medium 5.8)
- [CVE-2026-42245](https://insights.sbomify.com/CVE-2026-42245/): net-imap: Quadratic complexity when reading response literals (low 2.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42256 and fix it if it is affected.

What it is: CVE-2026-42256 is a medium-severity denial of service vulnerability in ruby net-imap, published on 9 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42256 in the wild and no public exploit code.

Affected packages and fixed versions:
- net-imap (RubyGems): affected from 0.4.0; fixed in 0.4.24
- net-imap (RubyGems): affected from 0.4.0; fixed in 0.4.24
- net-imap (RubyGems): affected from 0.5.0; fixed in 0.5.14
- net-imap (RubyGems): affected from 0.5.0; fixed in 0.5.14
- net-imap (RubyGems): affected from 0.6.0; fixed in 0.6.4
- net-imap (RubyGems): affected from 0.6.0; fixed in 0.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42256/ (Markdown: https://insights.sbomify.com/CVE-2026-42256/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42256
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42256
- OSV: https://osv.dev/vulnerability/CVE-2026-42256

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42256/
Summaries are generated and may contain mistakes; the official description above is the record.
