# CVE-2026-42258: net-imap: Command Injection via unvalidated Symbol inputs

> Attackers can inject IMAP commands via unvalidated Symbol arguments in the Ruby net-imap library, potentially executing arbitrary commands or modifying data.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 May 2026
- **Updated:** 1 Sep 2026
- **Also known as:** ALPINE-CVE-2026-42258, BELL-CVE-2026-42258, CLEANSTART-2026-SF71798, CLEANSTART-2026-TS16592, CLSA-2026-1783695736, DEBIAN-CVE-2026-42258, ECHO-6d52-c40e-a517, GHSA-75xq-5h9v-w6px, MINI-6f65-h4f7-mrrq, MINI-7wmp-hj27-655m, MINI-8mr6-4m75-6w7j, MINI-cqqp-mm74-wj3g, MINI-f38v-r742-q3wj, MINI-f8f6-2jq2-hxfx, MINI-fmqr-jp6r-rfv9, MINI-gh76-mrhx-jxqc, MINI-gv2g-f7mv-qgfq, MINI-hg62-9wcc-7mp7, MINI-pmvf-9cgp-hhc9, MINI-q5rq-mxqg-7c6g, MINI-qr9q-3q5f-h37h, MINI-qwrq-9x9p-86vg, MINI-rqv6-6wmw-fv4m, MINI-w59v-ppqg-gj95, MINI-wx5c-f93p-j755, UBUNTU-CVE-2026-42258

## What is CVE-2026-42258?

CVE-2026-42258 is a medium-severity command injection vulnerability in ruby net-imap, published on 9 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.4.24, 0.5.14, and 0.6.4, symbol arguments to commands are vulnerable to a CRLF Injection / IMAP Command injection via Symbol arguments passed to IMAP commands. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-42258?

6 open source packages ship an affected version, including net-imap. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net-imap` | RubyGems | All versions | 0.4.24 |
| `net-imap` | RubyGems | All versions | 0.4.24 |
| `net-imap` | RubyGems | From 0.5.0 | 0.5.14 |
| `net-imap` | RubyGems | From 0.5.0 | 0.5.14 |
| `net-imap` | RubyGems | From 0.6.0 | 0.6.4 |
| `net-imap` | RubyGems | From 0.6.0 | 0.6.4 |

Products: Ruby-Lang Net\.

## How do I fix CVE-2026-42258?

Upgrade net-imap to a fixed version for your release line: 0.4.24, 0.5.14 or 0.6.4.

## Is CVE-2026-42258 being exploited?

There is no known exploitation of CVE-2026-42258 in the wild and no public exploit code.

## Other vulnerabilities in ruby net-imap

- [CVE-2026-42246](https://insights.sbomify.com/CVE-2026-42246/): net-imap vulnerable to STARTTLS stripping via invalid response timing (high 7.6)
- [CVE-2026-42256](https://insights.sbomify.com/CVE-2026-42256/): net-imap: Denial of service via high iteration count for `SCRAM-*` authentication (medium 6.0)
- [CVE-2025-43857](https://insights.sbomify.com/CVE-2025-43857/): net-imap rubygem vulnerable to possible DoS by memory exhaustion (medium 6.0)
- [CVE-2026-42257](https://insights.sbomify.com/CVE-2026-42257/): net-imap: Command Injection via "raw" arguments to multiple commands (medium 5.8)
- [CVE-2026-42245](https://insights.sbomify.com/CVE-2026-42245/): net-imap: Quadratic complexity when reading response literals (low 2.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42258 and fix it if it is affected.

What it is: CVE-2026-42258 is a medium-severity command injection vulnerability in ruby net-imap, published on 9 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42258 in the wild and no public exploit code.

Affected packages and fixed versions:
- net-imap (RubyGems): affected all versions; fixed in 0.4.24
- net-imap (RubyGems): affected all versions; fixed in 0.4.24
- net-imap (RubyGems): affected from 0.5.0; fixed in 0.5.14
- net-imap (RubyGems): affected from 0.5.0; fixed in 0.5.14
- net-imap (RubyGems): affected from 0.6.0; fixed in 0.6.4
- net-imap (RubyGems): affected from 0.6.0; fixed in 0.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42258/ (Markdown: https://insights.sbomify.com/CVE-2026-42258/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42258
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42258
- OSV: https://osv.dev/vulnerability/CVE-2026-42258

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42258/
Summaries are generated and may contain mistakes; the official description above is the record.
