# CVE-2026-42260: open-websearch has SSRF in `fetchWebContent` MCP tool: bracketed IPv6 literals and non-resolving hostname check bypass `isPrivateOrLocalHostname`

> An attacker can bypass SSRF protections in Open-WebSearch to access internal resources via bracketed IPv6 literals or non-resolving hostnames.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-v228-72c7-fx8j

## What is CVE-2026-42260?

CVE-2026-42260 is a high-severity server-side request forgery vulnerability in Aas-ee open-webSearch, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Open-WebSearch is a multi-engine MCP server, CLI, and local daemon for agent web search and content retrieval. Prior to 2.1.7, isPublicHttpUrl / assertPublicHttpUrl in src/utils/urlSafety.ts do not recognize bracketed IPv6 literals and do not resolve DNS, which combine to allow non-blind SSRF with the response body returned to the caller. This vulnerability is fixed in 2.1.7.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-42260?

2 open source packages ship an affected version, including open-websearch.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-websearch` | npm | All versions | 2.1.7 |
| `open-websearch` | npm | All versions | 2.1.7 |

## How do I fix CVE-2026-42260?

Upgrade open-websearch to 2.1.7 or later.

## Is CVE-2026-42260 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42260 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42260 and fix it if it is affected.

What it is: CVE-2026-42260 is a high-severity server-side request forgery vulnerability in Aas-ee open-webSearch, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42260 exists.

Affected packages and fixed versions:
- open-websearch (npm): affected all versions; fixed in 2.1.7
- open-websearch (npm): affected all versions; fixed in 2.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42260/ (Markdown: https://insights.sbomify.com/CVE-2026-42260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42260
- OSV: https://osv.dev/vulnerability/CVE-2026-42260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42260/
Summaries are generated and may contain mistakes; the official description above is the record.
