CVE-2026-42266 JupyterLab has an Extension Manager API/GUI Policy Discrepancy, allowing 3rd party (malicious) extensions install via POST request

High 8.8 Published Updated

Attackers can bypass extension allow-lists to install malicious third-party extensions via POST requests, leading to potential code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-42266?

CVE-2026-42266 is a high-severity vulnerability in jupyterlab, published on 13 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.0.0 to 4.5.6, the allow-list of extensions that can be installed from PyPI Extension Manager (allowed_extensions_uris) is not correctly enforced by JupyterLab. The PyPI Extension Manager was not contained to packages listed on the default PyPI index. This vulnerability is fixed in 4.5.7.

Weakness: CWE-88, CWE-602

Which versions are affected by CVE-2026-42266?

4 open source packages ship an affected version, including jupyterlab. It affects 1 product.

PackageAffectedFixed in
jupyterlab BitnamiFrom 4.0.04.5.7
jupyterlab PyPIFrom 4.0.04.5.7
jupyterlab PyPIFrom 4.0.04.5.7
jupyterlab PyPIFrom 4.0.04.5.7

Products include Jupyter Jupyterlab.

How do I fix CVE-2026-42266?

Upgrade jupyterlab to 4.5.7 or later.

Is CVE-2026-42266 being exploited?

There is no known exploitation of CVE-2026-42266 in the wild and no public exploit code.

Sources

Also known as BIT-jupyterlab-2026-42266, CLEANSTART-2026-KE39444, CLEANSTART-2026-PS25216, DEBIAN-CVE-2026-42266, GHSA-37w4-hwhx-4rc4, PYSEC-2026-164 and 1 more.

Is CVE-2026-42266 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free