{"answers":{"affected":"4 open source packages ship an affected version, including jupyterlab. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-42266 in the wild and no public exploit code.","fix":"Upgrade jupyterlab to 4.5.7 or later.","what":"CVE-2026-42266 is a high-severity vulnerability in jupyterlab, published on 13 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42266 and fix it if it is affected.\n\nWhat it is: CVE-2026-42266 is a high-severity vulnerability in jupyterlab, published on 13 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42266 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jupyterlab (Bitnami): affected from 4.0.0; fixed in 4.5.7\n- jupyterlab (PyPI): affected from 4.0.0; fixed in 4.5.7\n- jupyterlab (PyPI): affected from 4.0.0; fixed in 4.5.7\n- jupyterlab (PyPI): affected from 4.0.0; fixed in 4.5.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42266/ (Markdown: https://insights.sbomify.com/CVE-2026-42266/index.md)","id":"CVE-2026-42266","markdown":"https://insights.sbomify.com/CVE-2026-42266/index.md","name":"CVE-2026-42266","record":{"aliases":["BIT-jupyterlab-2026-42266","CLEANSTART-2026-KE39444","CLEANSTART-2026-PS25216","DEBIAN-CVE-2026-42266","GHSA-37w4-hwhx-4rc4","PYSEC-2026-164","UBUNTU-CVE-2026-42266"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JupyterLab","requires_auth":"low_privilege","summary":"Attackers can bypass extension allow-lists to install malicious third-party extensions via POST requests, leading to potential code execution.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"jupyterlab","vendor":"jupyter"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"},{"id":"CWE-602","name":"Client-Side Enforcement of Server-Side Security"}],"description":"JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.0.0 to 4.5.6, the allow-list of extensions that can be installed from PyPI Extension Manager (allowed_extensions_uris) is not correctly enforced by JupyterLab. The PyPI Extension Manager was not contained to packages listed on the default PyPI index. This vulnerability is fixed in 4.5.7.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"JupyterLab has an Extension Manager API/GUI Policy Discrepancy, allowing 3rd party (malicious) extensions install via POST request","id":"CVE-2026-42266","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":4,"n_references":4,"next":{"headline":"Kimai: Formula Injection via tag names in XLSX export","id":"CVE-2026-42267"},"packages":[{"ecosystem":"Bitnami","fixed":["4.5.7"],"introduced":["4.0.0"],"last_affected":[],"package":"jupyterlab","purl":"pkg:bitnami/jupyterlab","source":"BIT-jupyterlab-2026-42266"},{"ecosystem":"PyPI","fixed":["4.5.7"],"introduced":["4.0.0"],"last_affected":[],"package":"jupyterlab","purl":null,"source":"GHSA-37w4-hwhx-4rc4"},{"ecosystem":"PyPI","fixed":["4.5.7"],"introduced":["4.0.0"],"last_affected":[],"package":"jupyterlab","purl":"pkg:pypi/jupyterlab","source":"GHSA-37w4-hwhx-4rc4"},{"ecosystem":"PyPI","fixed":["4.5.7"],"introduced":["4.0.0"],"last_affected":[],"package":"jupyterlab","purl":"pkg:pypi/jupyterlab","source":"PYSEC-2026-164"}],"prev":{"headline":"Axios: Prototype pollution read-side gadgets in HTTP adapter allow credential injection and request hijacking","id":"CVE-2026-42264"},"products":["jupyterlab"],"published":"2026-05-13","related":[{"cvss_score":10,"headline":"Remote Code Execution (RCE) vulnerability in jupyterlab extension template `update-integration-tests` GitHub Action","id":"CVE-2024-39700","kev_date_added":null,"published":"2024-07-16"},{"cvss_score":8.6,"headline":"jupyterlab: Command linker attributes in HTML enable one-click command execution from untrusted content","id":"CVE-2026-42557","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":7.6,"headline":"HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering","id":"CVE-2024-43805","kev_date_added":null,"published":"2024-08-28"},{"cvss_score":7.4,"headline":"JupyterLab: XSS due to lack of sanitization of the action attribute of an html \u003cform\u003e","id":"CVE-2021-32797","kev_date_added":null,"published":"2021-08-09"},{"cvss_score":2.1,"headline":"JupyterLab LaTeX typesetter links did not enforce `noopener` attribute","id":"CVE-2025-59842","kev_date_added":null,"published":"2025-09-26"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-28","vendors":["jupyterlab"]},"summary":"Attackers can bypass extension allow-lists to install malicious third-party extensions via POST requests, leading to potential code execution.","url":"https://insights.sbomify.com/CVE-2026-42266/"}