# CVE-2026-42266: JupyterLab has an Extension Manager API/GUI Policy Discrepancy, allowing 3rd party (malicious) extensions install via POST request

> Attackers can bypass extension allow-lists to install malicious third-party extensions via POST requests, leading to potential code execution.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 28 Aug 2026
- **Also known as:** BIT-jupyterlab-2026-42266, CLEANSTART-2026-KE39444, CLEANSTART-2026-PS25216, DEBIAN-CVE-2026-42266, GHSA-37w4-hwhx-4rc4, PYSEC-2026-164, UBUNTU-CVE-2026-42266

## What is CVE-2026-42266?

CVE-2026-42266 is a high-severity vulnerability in jupyterlab, published on 13 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.0.0 to 4.5.6, the allow-list of extensions that can be installed from PyPI Extension Manager (allowed_extensions_uris) is not correctly enforced by JupyterLab. The PyPI Extension Manager was not contained to packages listed on the default PyPI index. This vulnerability is fixed in 4.5.7.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command), CWE-602 (Client-Side Enforcement of Server-Side Security)

## Which versions are affected by CVE-2026-42266?

4 open source packages ship an affected version, including jupyterlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyterlab` | Bitnami | From 4.0.0 | 4.5.7 |
| `jupyterlab` | PyPI | From 4.0.0 | 4.5.7 |
| `jupyterlab` | PyPI | From 4.0.0 | 4.5.7 |
| `jupyterlab` | PyPI | From 4.0.0 | 4.5.7 |

Products: Jupyter Jupyterlab.

## How do I fix CVE-2026-42266?

Upgrade jupyterlab to 4.5.7 or later.

## Is CVE-2026-42266 being exploited?

There is no known exploitation of CVE-2026-42266 in the wild and no public exploit code.

## Other vulnerabilities in jupyterlab

- [CVE-2024-39700](https://insights.sbomify.com/CVE-2024-39700/): Remote Code Execution (RCE) vulnerability in jupyterlab extension template `update-integration-tests` GitHub Action (critical 10.0)
- [CVE-2026-42557](https://insights.sbomify.com/CVE-2026-42557/): jupyterlab: Command linker attributes in HTML enable one-click command execution from untrusted content (high 8.6)
- [CVE-2024-43805](https://insights.sbomify.com/CVE-2024-43805/): HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering (high 7.6)
- [CVE-2021-32797](https://insights.sbomify.com/CVE-2021-32797/): JupyterLab: XSS due to lack of sanitization of the action attribute of an html <form> (high 7.4)
- [CVE-2025-59842](https://insights.sbomify.com/CVE-2025-59842/): JupyterLab LaTeX typesetter links did not enforce `noopener` attribute (low 2.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42266 and fix it if it is affected.

What it is: CVE-2026-42266 is a high-severity vulnerability in jupyterlab, published on 13 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42266 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyterlab (Bitnami): affected from 4.0.0; fixed in 4.5.7
- jupyterlab (PyPI): affected from 4.0.0; fixed in 4.5.7
- jupyterlab (PyPI): affected from 4.0.0; fixed in 4.5.7
- jupyterlab (PyPI): affected from 4.0.0; fixed in 4.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42266/ (Markdown: https://insights.sbomify.com/CVE-2026-42266/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42266
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42266
- OSV: https://osv.dev/vulnerability/CVE-2026-42266

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42266/
Summaries are generated and may contain mistakes; the official description above is the record.
