# CVE-2026-42268: ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators

> An unsigned integer underflow in ModSecurity WAF operators causes an unhandled exception, leading to denial of service when specific rules are configured.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 14 May 2026
- **Also known as:** BIT-modsecurity-2026-42268, BIT-modsecurity2-2026-42268, DEBIAN-CVE-2026-42268, GHSA-vwr3-7x7g-7p9w, UBUNTU-CVE-2026-42268

## What is CVE-2026-42268?

CVE-2026-42268 is a high-severity vulnerability in owasp-modsecurity ModSecurity, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.

Weakness: CWE-248 (Uncaught Exception), CWE-191 (Integer Underflow (Wrap or Wraparound))

## Which versions are affected by CVE-2026-42268?

2 open source packages ship an affected version, including modsecurity and modsecurity2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modsecurity` | Bitnami | From 3.0.0 | 3.0.15 |
| `modsecurity2` | Bitnami | From 3.0.0 | 3.0.15 |

Products: Owasp Modsecurity.

## How do I fix CVE-2026-42268?

Upgrade modsecurity to 3.0.15 or later.

## Is CVE-2026-42268 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42268 exists.

## Other vulnerabilities in owasp-modsecurity ModSecurity

- [CVE-2026-52747](https://insights.sbomify.com/CVE-2026-52747/): Security feature bypass in ModSecurity (high 8.6)
- [CVE-2024-1019](https://insights.sbomify.com/CVE-2024-1019/): WAF bypass of the ModSecurity v3 release line (high 8.6)
- [CVE-2026-30923](https://insights.sbomify.com/CVE-2026-30923/): libModSecurity3 denial of service via segfault when using t:hexDecode on single-character query strings (high 8.2)
- [CVE-2025-48866](https://insights.sbomify.com/CVE-2025-48866/): ModSecurity has possible DoS vulnerability in sanitiseArg action (high 7.5)
- [CVE-2023-38285](https://insights.sbomify.com/CVE-2023-38285/): Trustwave ModSecurity 3.x before 3.0.10 has Inefficient Algorithmic Complexity. (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42268 and fix it if it is affected.

What it is: CVE-2026-42268 is a high-severity vulnerability in owasp-modsecurity ModSecurity, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42268 exists.

Affected packages and fixed versions:
- modsecurity (Bitnami): affected from 3.0.0; fixed in 3.0.15
- modsecurity2 (Bitnami): affected from 3.0.0; fixed in 3.0.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42268/ (Markdown: https://insights.sbomify.com/CVE-2026-42268/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42268
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42268
- OSV: https://osv.dev/vulnerability/CVE-2026-42268

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42268/
Summaries are generated and may contain mistakes; the official description above is the record.
