# CVE-2026-42270: countly-server: Unauthenticated Denial of Service (DoS) via Unhandled Stream Exception

> Unauthenticated attackers can crash the Countly server by sending crafted requests to image routes, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** GHSA-86cv-qwp9-jwp3

## What is CVE-2026-42270?

CVE-2026-42270 is a high-severity denial of service vulnerability in countly-server, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

countly-server is the server-side part of Countly, a product analytics solution. Prior to 24.05.50 and 25.03.44, star-rating/images/ and dashboards/images/screenshots/ are among public image and screenshot routes using the local fs storage backend that call getStream and pipe filesystem streams to HTTP responses without an error listener. An unauthenticated request containing a URL-encoded dot can make createReadStream open a directory, emit an asynchronous EISDIR error, and terminate the Node.js process as an unhandled exception, allowing repeated requests to keep the analytics API unavailable. The affected routes also include /appimages/*, /memberimages/*, and */screenshots/*. This issue is fixed in versions 24.05.50 and 25.03.44.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-42270?


## How do I fix CVE-2026-42270?

No fix has been published for CVE-2026-42270 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42270 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42270 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42270 and fix it if it is affected.

What it is: CVE-2026-42270 is a high-severity denial of service vulnerability in countly-server, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42270 exists.

Affected product: countly-server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42270/ (Markdown: https://insights.sbomify.com/CVE-2026-42270/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42270
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42270
- OSV: https://osv.dev/vulnerability/CVE-2026-42270

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42270/
Summaries are generated and may contain mistakes; the official description above is the record.
