# CVE-2026-42271: BerriAI LiteLLM Command Injection

> Authenticated users can execute arbitrary commands on the host via MCP stdio test endpoints due to missing role checks.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Yes, since 8 Jun 2026 (CISA KEV)
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 15 Jul 2026
- **Also known as:** ECHO-c4c7-aed2-2231, GHSA-v4p8-mg3p-g94g, MINI-2r2w-xq7g-q5j6, MINI-45w8-qv5q-qqcp, MINI-4r4g-687v-g9j9, MINI-7qv8-pqwr-2c4r, MINI-965q-5x27-w7x2, MINI-mwp4-g93c-7fg7, PYSEC-2026-2599

## What is CVE-2026-42271?

CVE-2026-42271 is a high-severity command injection vulnerability in BerriAI litellm, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-42271?

3 open source packages ship an affected version, including litellm. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | From 1.74.2 | 1.83.7 |
| `litellm` | PyPI | From 1.74.2 | 1.83.7 |
| `litellm` | PyPI | From 1.74.2 | 1.83.7 |

Products: Litellm Litellm, Redhat Openshift Ai.

## How do I fix CVE-2026-42271?

Upgrade litellm to 1.83.7 or later. US federal agencies must fix it by 22 Jun 2026.

## Is CVE-2026-42271 being exploited?

Yes. Attackers have exploited CVE-2026-42271 in the wild since at least 8 Jun 2026.

Public exploit code:

- The code for personally reproducing the corresponding vulnerability (github_poc): https://github.com/learner202649/CVE-2026-42271-PoC
- BerriAI LiteLLM Proxy MCP Test Endpoint Command Execution (metasploit)
- CVE-2026-42271 - Draft (github_poc): https://github.com/HORKimhab/CVE-2026-42271
- LiteLLM - Command Injection (nuclei): http/cves/2026/CVE-2026-42271.yaml

## Other vulnerabilities in BerriAI litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)
- [CVE-2026-49468](https://insights.sbomify.com/CVE-2026-49468/): LiteLLM: Authentication Bypass via Host Header Injection (critical 9.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42271 and fix it if it is affected.

What it is: CVE-2026-42271 is a high-severity command injection vulnerability in BerriAI litellm, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2026-42271 in the wild since at least 8 Jun 2026.

Affected packages and fixed versions:
- litellm (PyPI): affected from 1.74.2; fixed in 1.83.7
- litellm (PyPI): affected from 1.74.2; fixed in 1.83.7
- litellm (PyPI): affected from 1.74.2; fixed in 1.83.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42271/ (Markdown: https://insights.sbomify.com/CVE-2026-42271/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42271
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42271
- OSV: https://osv.dev/vulnerability/CVE-2026-42271

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42271/
Summaries are generated and may contain mistakes; the official description above is the record.
