CVE-2026-42280 Improper Permission Checking in Auth.js SDK
Attackers can retrieve user profile information by providing a crafted invalid ID token with a valid access token in the Auth0.js SDK.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42280?
CVE-2026-42280 is a high-severity missing authorization vulnerability in auth0.js, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Auth0.js is a client-side JavaScript library for Auth0. From 8.11.0 to 9.32.0, under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided. This vulnerability is fixed in 10.0.0.
Weakness: CWE-863
Which versions are affected by CVE-2026-42280?
2 open source packages ship an affected version, including auth0-js. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
auth0-js npm | From 8.11.0 | 10.0.0 |
auth0-js npm | From 8.11.0 | 10.0.0 |
Products include Auth0 Auth0.js.
How do I fix CVE-2026-42280?
Upgrade auth0-js to 10.0.0 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-42280 being exploited?
There is no known exploitation of CVE-2026-42280 in the wild and no public exploit code.
Other vulnerabilities in auth0.js
Sources
Also known as GHSA-8qjv-jj2q-x832.