# CVE-2026-42280: Improper Permission Checking in Auth.js SDK

> Attackers can retrieve user profile information by providing a crafted invalid ID token with a valid access token in the Auth0.js SDK.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-8qjv-jj2q-x832

## What is CVE-2026-42280?

CVE-2026-42280 is a high-severity missing authorization vulnerability in auth0.js, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Auth0.js is a client-side JavaScript library for Auth0. From 8.11.0 to 9.32.0, under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided. This vulnerability is fixed in 10.0.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-42280?

2 open source packages ship an affected version, including auth0-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0-js` | npm | From 8.11.0 | 10.0.0 |
| `auth0-js` | npm | From 8.11.0 | 10.0.0 |

Products: Auth0 Auth0.js.

## How do I fix CVE-2026-42280?

Upgrade auth0-js to 10.0.0 or later.

## Is CVE-2026-42280 being exploited?

There is no known exploitation of CVE-2026-42280 in the wild and no public exploit code.

## Other vulnerabilities in auth0.js

- [CVE-2018-6873](https://insights.sbomify.com/CVE-2018-6873/): Auth bypass in n/a (critical 9.8)
- [CVE-2018-6874](https://insights.sbomify.com/CVE-2018-6874/): Cross-Site Request Forgery (CSRF) in Auth0 (high 8.8)
- [CVE-2018-7307](https://insights.sbomify.com/CVE-2018-7307/): Auth0-js bypasses CSRF checks (high 8.8)
- [CVE-2020-15125](https://insights.sbomify.com/CVE-2020-15125/): Authorization header is not sanitized in an error object in auth0 (high 7.7)
- [CVE-2017-17068](https://insights.sbomify.com/CVE-2017-17068/): auth0-js Privilege Escalation Vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42280 and fix it if it is affected.

What it is: CVE-2026-42280 is a high-severity missing authorization vulnerability in auth0.js, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42280 in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0-js (npm): affected from 8.11.0; fixed in 10.0.0
- auth0-js (npm): affected from 8.11.0; fixed in 10.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42280/ (Markdown: https://insights.sbomify.com/CVE-2026-42280/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42280
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42280
- OSV: https://osv.dev/vulnerability/CVE-2026-42280

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42280/
Summaries are generated and may contain mistakes; the official description above is the record.
