# CVE-2026-42282: n8n-MCP: Sensitive MCP tool-call arguments logged on authenticated requests in HTTP mode

> Authenticated attackers can expose sensitive credentials and API keys in server logs when using HTTP transport mode in n8n-MCP.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-wg4g-395p-mqv3

## What is CVE-2026-42282?

CVE-2026-42282 is a medium-severity vulnerability in czlonkowski n8n-mcp, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n-MCP is an MCP server that provides AI assistants access to n8n node documentation, properties, and operations. Prior to version 2.47.13, when n8n-mcp runs in HTTP transport mode, authenticated MCP tools/call requests had their full arguments and JSON-RPC params written to server logs by the request dispatcher and several sibling code paths before any redaction. When a tool call carries credential material — most notably n8n_manage_credentials.data — the raw values can be persisted in logs. In deployments where logs are collected, forwarded to external systems, or viewable outside the request trust boundary (shared log storage, SIEM pipelines, support/ops access), this can result in disclosure of: bearer tokens and OAuth credentials sent through n8n_manage_credentials, per-tenant API keys and webhook auth headers embedded in tool arguments, arbitrary secret-bearing payloads passed to any MCP tool. The issue requires authentication (AUTH_TOKEN accepted by the server), so unauthenticated callers cannot trigger it; the runtime exposure is also reduced by an existing console-silencing layer in HTTP mode, but that layer is fragile and the values are still constructed and passed into the logger. This issue has been patched in version 2.47.13.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2026-42282?

2 open source packages ship an affected version, including n8n-mcp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n-mcp` | npm | All versions | 2.47.13 |
| `n8n-mcp` | npm | All versions | 2.47.13 |

Products: N8n-Mcp N8n-Mcp.

## How do I fix CVE-2026-42282?

Upgrade n8n-mcp to 2.47.13 or later.

## Is CVE-2026-42282 being exploited?

There is no known exploitation of CVE-2026-42282 in the wild and no public exploit code.

## Other vulnerabilities in czlonkowski n8n-mcp

- [CVE-2026-54052](https://insights.sbomify.com/CVE-2026-54052/): n8n-MCP: Cross-tenant access to workflow version backups in multi-tenant HTTP deployments (critical 9.9)
- [CVE-2026-42449](https://insights.sbomify.com/CVE-2026-42449/): n8n-MCP: IPv4-mapped IPv6 addresses bypass SSRF protection in validateUrlSync(), enabling full SSRF for SDK embedders (high 8.5)
- [CVE-2026-39974](https://insights.sbomify.com/CVE-2026-39974/): n8n-MCP has an Authenticated SSRF via instance-URL header in multi-tenant HTTP mode (high 8.5)
- [CVE-2026-45707](https://insights.sbomify.com/CVE-2026-45707/): n8n-MCP: Multi-tenant MCP requests fall back to process-level n8n credentials when tenant headers are absent or incomplete (high 8.1)
- [CVE-2026-44694](https://insights.sbomify.com/CVE-2026-44694/): n8n-MCP: Authenticated SSRF in n8n-mcp webhook and API client paths (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42282 and fix it if it is affected.

What it is: CVE-2026-42282 is a medium-severity vulnerability in czlonkowski n8n-mcp, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42282 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n-mcp (npm): affected all versions; fixed in 2.47.13
- n8n-mcp (npm): affected all versions; fixed in 2.47.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42282/ (Markdown: https://insights.sbomify.com/CVE-2026-42282/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42282
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42282
- OSV: https://osv.dev/vulnerability/CVE-2026-42282

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42282/
Summaries are generated and may contain mistakes; the official description above is the record.
