# CVE-2026-42283: DevSpace UI Server WebSocket CheckOrigin does not validate source

> A malicious website can access DevSpace UI server endpoints via cross-origin WebSocket connections, potentially exposing sensitive data.

- **Severity:** High 7.7 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 16 May 2026
- **Also known as:** GHSA-hqwm-7x7x-8379, GO-2026-5433

## What is CVE-2026-42283?

CVE-2026-42283 is a high-severity missing authorization vulnerability in devspace-sh devspace, published on 14 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

DevSpace is a client-only developer tool for cloud-native development with Kubernetes. Prior to 6.3.21, DevSpace's UI server WebSocket accepts connections from all origins by default, and therefore several endpoints are exposed via this WebSocket. When a developer runs the DevSpace UI and at the same time uses a browser to access the internet, a malicious website they visit can use their browser to establish a cross-origin WebSocket connection to ws://127.0.0.1:8090. This vulnerability is fixed in 6.3.21.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-42283?

3 open source packages ship an affected version, including github.com/loft-sh/devspace. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/loft-sh/devspace` | Go | All versions | None |
| `github.com/loft-sh/devspace` | Go | From 6.3.20 | 6.3.21 |
| `github.com/loft-sh/devspace` | Go | From 6.3.20 | 6.3.21 |

Products: Devspace Devspace.

## How do I fix CVE-2026-42283?

Upgrade github.com/loft-sh/devspace to 6.3.21 or later.

## Is CVE-2026-42283 being exploited?

There is no known exploitation of CVE-2026-42283 in the wild and no public exploit code.

## Other vulnerabilities in devspace-sh devspace

- [CVE-2020-15391](https://insights.sbomify.com/CVE-2020-15391/): DevSpace vulnerable to remote code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42283 and fix it if it is affected.

What it is: CVE-2026-42283 is a high-severity missing authorization vulnerability in devspace-sh devspace, published on 14 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42283 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/loft-sh/devspace (Go): affected all versions; no fix listed
- github.com/loft-sh/devspace (Go): affected from 6.3.20; fixed in 6.3.21
- github.com/loft-sh/devspace (Go): affected from 6.3.20; fixed in 6.3.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42283/ (Markdown: https://insights.sbomify.com/CVE-2026-42283/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42283
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42283
- OSV: https://osv.dev/vulnerability/CVE-2026-42283

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42283/
Summaries are generated and may contain mistakes; the official description above is the record.
