# CVE-2026-42284: GitPython: Unsafe option check validates multi_options before shlex.split transforms it

> Attackers can execute arbitrary code during Git clone operations by bypassing option validation in GitPython, allowing malicious hooks to run.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 9 May 2026
- **Also known as:** DEBIAN-CVE-2026-42284, ECHO-ccb7-6d4f-be3e, GHSA-x2qx-6953-8485, MINI-242j-jwxh-4f7q, MINI-f45q-qwvr-xcrv, PYSEC-2026-2161, ROOT-APP-PYPI-CVE-2026-42284, UBUNTU-CVE-2026-42284

## What is CVE-2026-42284?

CVE-2026-42284 is a high-severity command injection vulnerability in gitpython-developers GitPython, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GitPython is a python library used to interact with Git repositories. Prior to version 3.1.47, _clone() validates multi_options as the original list, then executes shlex.split(" ".join(multi_options)). A string like "--branch main --config core.hooksPath=/x" passes validation (starts with --branch), but after split becomes ["--branch", "main", "--config", "core.hooksPath=/x"]. Git applies the config and executes attacker hooks during clone. This issue has been patched in version 3.1.47.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-42284?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.47 |
| `gitpython` | PyPI | All versions | 3.1.47 |
| `GitPython` | PyPI | All versions | 3.1.47 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-42284?

Upgrade gitpython to 3.1.47 or later.

## Is CVE-2026-42284 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42284 exists.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42284 and fix it if it is affected.

What it is: CVE-2026-42284 is a high-severity command injection vulnerability in gitpython-developers GitPython, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42284 exists.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.47
- gitpython (PyPI): affected all versions; fixed in 3.1.47
- GitPython (PyPI): affected all versions; fixed in 3.1.47

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42284/ (Markdown: https://insights.sbomify.com/CVE-2026-42284/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42284
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42284
- OSV: https://osv.dev/vulnerability/CVE-2026-42284

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42284/
Summaries are generated and may contain mistakes; the official description above is the record.
