CVE-2026-42285 GoBGP: Panic in AdjRib.Update via malformed BGP Update message (Nil Pointer Dereference)

High 7.5 Published Updated

An unauthenticated remote attacker can crash the GoBGP service by sending a malformed BGP UPDATE message, causing a denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-42285?

CVE-2026-42285 is a high-severity vulnerability in osrg gobgp, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language. In version 4.4.0, an unauthenticated remote BGP peer can trigger a fatal panic in GoBGP by sending a specially crafted BGP UPDATE message. When the server receives a message with inconsistent attribute lengths, it improperly handles the internal state transition to a "withdraw" action, leading to a nil pointer dereference in the AdjRib.Update function. This causes the entire GoBGP process to crash, resulting in a complete loss of service availability. This issue has been patched in version 4.5.0.

Weakness: CWE-476

Which versions are affected by CVE-2026-42285?

3 open source packages ship an affected version, including github.com/osrg/gobgp/v4. It affects 1 product.

PackageAffectedFixed in
github.com/osrg/gobgp/v4 GoFrom 4.4.04.5.0
github.com/osrg/gobgp/v4 GoFrom 4.4.04.5.0
github.com/osrg/gobgp/v4 GoFrom 4.4.04.5.0

Products include Osrg Gobgp.

How do I fix CVE-2026-42285?

Upgrade github.com/osrg/gobgp/v4 to 4.5.0 or later.

Is CVE-2026-42285 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42285 exists.

Sources

Also known as DEBIAN-CVE-2026-42285, GHSA-p3w2-64xm-833j, GO-2026-5525.

Is CVE-2026-42285 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free