# CVE-2026-42285: GoBGP: Panic in AdjRib.Update via malformed BGP Update message (Nil Pointer Dereference)

> An unauthenticated remote attacker can crash the GoBGP service by sending a malformed BGP UPDATE message, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** DEBIAN-CVE-2026-42285, GHSA-p3w2-64xm-833j, GO-2026-5525

## What is CVE-2026-42285?

CVE-2026-42285 is a high-severity vulnerability in osrg gobgp, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language. In version 4.4.0, an unauthenticated remote BGP peer can trigger a fatal panic in GoBGP by sending a specially crafted BGP UPDATE message. When the server receives a message with inconsistent attribute lengths, it improperly handles the internal state transition to a "withdraw" action, leading to a nil pointer dereference in the AdjRib.Update function. This causes the entire GoBGP process to crash, resulting in a complete loss of service availability. This issue has been patched in version 4.5.0.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-42285?

3 open source packages ship an affected version, including github.com/osrg/gobgp/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/osrg/gobgp/v4` | Go | From 4.4.0 | 4.5.0 |
| `github.com/osrg/gobgp/v4` | Go | From 4.4.0 | 4.5.0 |
| `github.com/osrg/gobgp/v4` | Go | From 4.4.0 | 4.5.0 |

Products: Osrg Gobgp.

## How do I fix CVE-2026-42285?

Upgrade github.com/osrg/gobgp/v4 to 4.5.0 or later.

## Is CVE-2026-42285 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42285 exists.

## Other vulnerabilities in osrg gobgp

- [CVE-2025-43971](https://insights.sbomify.com/CVE-2025-43971/): GoBGP panics due to a zero value for softwareVersionLen (high 8.6)
- [CVE-2026-41642](https://insights.sbomify.com/CVE-2026-41642/): GoBGP: Remote Denial of Service (Panic) via Malformed Well-known Path Attribute (high 7.5)
- [CVE-2026-41643](https://insights.sbomify.com/CVE-2026-41643/): GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE (high 7.5)
- [CVE-2026-37461](https://insights.sbomify.com/CVE-2026-37461/): GoBGP has an out-of-bounds read in the ParseIP6Extended function (high 7.5)
- [CVE-2026-30405](https://insights.sbomify.com/CVE-2026-30405/): GoBGP vulnerable to a denial of service via the NEXT_HOP path attribute (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42285 and fix it if it is affected.

What it is: CVE-2026-42285 is a high-severity vulnerability in osrg gobgp, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42285 exists.

Affected packages and fixed versions:
- github.com/osrg/gobgp/v4 (Go): affected from 4.4.0; fixed in 4.5.0
- github.com/osrg/gobgp/v4 (Go): affected from 4.4.0; fixed in 4.5.0
- github.com/osrg/gobgp/v4 (Go): affected from 4.4.0; fixed in 4.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42285/ (Markdown: https://insights.sbomify.com/CVE-2026-42285/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42285
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42285
- OSV: https://osv.dev/vulnerability/CVE-2026-42285

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42285/
Summaries are generated and may contain mistakes; the official description above is the record.
