# CVE-2026-42291: SysReptor: Read-write access to personal notes by sharing-link creation with no authorization in SysReptor Professional

> Authenticated attackers can read and modify other users' personal notes by creating sharing links without proper authorization checks.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-pcpr-q2qj-3v43

## What is CVE-2026-42291?

CVE-2026-42291 is a medium-severity missing authorization vulnerability in Syslifters sysreptor, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SysReptor is a fully customizable pentest reporting platform. From version 2026.4 to before version 2026.27, the endpoints for reading and creating sharing links for personal notes is not properly authorized. This allows authenticated attackers who obtain the note ID of victim users to list and create sharing links to those users' personal notes. This gives attackers read and write access to notes of other users. This exploit works in both SysReptor Professional and Community. In Community it has, however, no impact because all users have superuser permissions and can list personal notes of other users at /admin/pentests/usernotebookpage/. This issue has been patched in version 2026.27.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-42291?


## How do I fix CVE-2026-42291?

No fix has been published for CVE-2026-42291 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42291 being exploited?

There is no known exploitation of CVE-2026-42291 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42291 and fix it if it is affected.

What it is: CVE-2026-42291 is a medium-severity missing authorization vulnerability in Syslifters sysreptor, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42291 in the wild and no public exploit code.

Affected product: Syslifters sysreptor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42291/ (Markdown: https://insights.sbomify.com/CVE-2026-42291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42291
- OSV: https://osv.dev/vulnerability/CVE-2026-42291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42291/
Summaries are generated and may contain mistakes; the official description above is the record.
