# CVE-2026-42301: Improper Input Validation leading to Improper Control of Generation of Code ('Code Injection') in pyp2spec

> Attackers can execute arbitrary commands on build machines by injecting RPM macros into PyPI metadata processed by pyp2spec.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-r35x-v8p8-xvhw, PYSEC-2026-3003

## What is CVE-2026-42301?

CVE-2026-42301 is a high-severity code injection vulnerability in befeleme pyp2spec, published on 9 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

pyp2spec generates working Fedora RPM spec file for Python projects. Prior to version 0.14.1, pyp2spec was writing PyPI package metadata (e.g. the summary field) into the generated spec file without escaping RPM macro directives. When a packager then runs rpmbuild, those directives get evaluated, so a malicious package can execute arbitrary commands on the build machine. This issue has been patched in version 0.14.1.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-42301?

3 open source packages ship an affected version, including pyp2spec.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyp2spec` | PyPI | All versions | 0.14.1 |
| `pyp2spec` | PyPI | All versions | 0.14.1 |
| `pyp2spec` | PyPI | All versions | 0.14.1 |

## How do I fix CVE-2026-42301?

Upgrade pyp2spec to 0.14.1 or later.

## Is CVE-2026-42301 being exploited?

There is no known exploitation of CVE-2026-42301 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42301 and fix it if it is affected.

What it is: CVE-2026-42301 is a high-severity code injection vulnerability in befeleme pyp2spec, published on 9 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42301 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyp2spec (PyPI): affected all versions; fixed in 0.14.1
- pyp2spec (PyPI): affected all versions; fixed in 0.14.1
- pyp2spec (PyPI): affected all versions; fixed in 0.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42301/ (Markdown: https://insights.sbomify.com/CVE-2026-42301/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42301
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42301
- OSV: https://osv.dev/vulnerability/CVE-2026-42301

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42301/
Summaries are generated and may contain mistakes; the official description above is the record.
