CVE-2026-42302 FastGPT: Unauthenticated Remote Code Execution (RCE) via code-server Misconfiguration in agent-sandbox

Critical 9.8 Published Updated

Unauthenticated attackers can execute arbitrary code in the agent-sandbox due to a misconfigured code-server binding, requiring an upgrade to FastGPT.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-42302?

CVE-2026-42302 is a critical authentication bypass vulnerability in labring FastGPT, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

FastGPT is an AI Agent building platform. From version 4.14.10 to before version 4.14.13, the agent-sandbox component of FastGPT is vulnerable to unauthenticated Remote Code Execution (RCE). The startup script entrypoint.sh initializes code-server with the --auth none flag and binds the service to all network interfaces (0.0.0.0:8080). This configuration allows any user with network access to the port to bypass authentication and gain full control over the sandbox environment. This issue has been patched in version 4.14.13.

Weakness: CWE-306

Which versions are affected by CVE-2026-42302?

How do I fix CVE-2026-42302?

No fix has been published for CVE-2026-42302 yet. Limit exposure of the affected software until one is available.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-42302 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42302 exists.

Sources

Also known as GHSA-34rc-438g-7w78.

Is CVE-2026-42302 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free