{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42302 exists.","fix":"No fix has been published for CVE-2026-42302 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-42302 is a critical authentication bypass vulnerability in labring FastGPT, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42302 and fix it if it is affected.\n\nWhat it is: CVE-2026-42302 is a critical authentication bypass vulnerability in labring FastGPT, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42302 exists.\n\nAffected product: labring FastGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42302/ (Markdown: https://insights.sbomify.com/CVE-2026-42302/index.md)","id":"CVE-2026-42302","markdown":"https://insights.sbomify.com/CVE-2026-42302/index.md","name":"CVE-2026-42302","record":{"aliases":["GHSA-34rc-438g-7w78"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"AI Agent Platform","requires_auth":"none","summary":"Unauthenticated attackers can execute arbitrary code in the agent-sandbox due to a misconfigured code-server binding, requiring an upgrade to FastGPT.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"FastGPT is an AI Agent building platform. From version 4.14.10 to before version 4.14.13, the agent-sandbox component of FastGPT is vulnerable to unauthenticated Remote Code Execution (RCE). The startup script entrypoint.sh initializes code-server with the --auth none flag and binds the service to all network interfaces (0.0.0.0:8080). This configuration allows any user with network access to the port to bypass authentication and gain full control over the sandbox environment. This issue has been patched in version 4.14.13.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"FastGPT: Unauthenticated Remote Code Execution (RCE) via code-server Misconfiguration in agent-sandbox","id":"CVE-2026-42302","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"Fides: Privacy Request Identity Verification Bypass Vulnerability via Duplicate Detection","id":"CVE-2026-42303"},"packages":[],"prev":{"headline":"Improper Input Validation leading to Improper Control of Generation of Code ('Code Injection') in pyp2spec","id":"CVE-2026-42301"},"products":["FastGPT"],"published":"2026-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-12","vendors":["labring"]},"summary":"Unauthenticated attackers can execute arbitrary code in the agent-sandbox due to a misconfigured code-server binding, requiring an upgrade to FastGPT.","url":"https://insights.sbomify.com/CVE-2026-42302/"}