# CVE-2026-42302: FastGPT: Unauthenticated Remote Code Execution (RCE) via code-server Misconfiguration in agent-sandbox

> Unauthenticated attackers can execute arbitrary code in the agent-sandbox due to a misconfigured code-server binding, requiring an upgrade to FastGPT.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-34rc-438g-7w78

## What is CVE-2026-42302?

CVE-2026-42302 is a critical authentication bypass vulnerability in labring FastGPT, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FastGPT is an AI Agent building platform. From version 4.14.10 to before version 4.14.13, the agent-sandbox component of FastGPT is vulnerable to unauthenticated Remote Code Execution (RCE). The startup script entrypoint.sh initializes code-server with the --auth none flag and binds the service to all network interfaces (0.0.0.0:8080). This configuration allows any user with network access to the port to bypass authentication and gain full control over the sandbox environment. This issue has been patched in version 4.14.13.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-42302?


## How do I fix CVE-2026-42302?

No fix has been published for CVE-2026-42302 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42302 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42302 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42302 and fix it if it is affected.

What it is: CVE-2026-42302 is a critical authentication bypass vulnerability in labring FastGPT, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42302 exists.

Affected product: labring FastGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42302/ (Markdown: https://insights.sbomify.com/CVE-2026-42302/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42302
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42302
- OSV: https://osv.dev/vulnerability/CVE-2026-42302

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42302/
Summaries are generated and may contain mistakes; the official description above is the record.
