{"answers":{"affected":"3 open source packages ship an affected version, including ethyca-fides.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42303 exists.","fix":"Upgrade ethyca-fides to 2.83.2 or later.","what":"CVE-2026-42303 is a medium-severity vulnerability in ethyca fides, published on 12 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-42303 and fix it if it is affected.\n\nWhat it is: CVE-2026-42303 is a medium-severity vulnerability in ethyca fides, published on 12 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42303 exists.\n\nAffected packages and fixed versions:\n- ethyca-fides (PyPI): affected from 2.75.0; fixed in 2.83.2\n- ethyca-fides (PyPI): affected from 2.75.0; fixed in 2.83.2\n- ethyca-fides (PyPI): affected from 2.75.0; fixed in 2.83.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42303/ (Markdown: https://insights.sbomify.com/CVE-2026-42303/index.md)","id":"CVE-2026-42303","markdown":"https://insights.sbomify.com/CVE-2026-42303/index.md","name":"CVE-2026-42303","record":{"aliases":["GHSA-qx5f-ghc2-7g5c","PYSEC-2026-2471"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Privacy engineering platform","requires_auth":"none","summary":"Attackers can bypass identity verification to approve privacy requests, leading to unauthorized data deletion in Fides deployments with specific features enabled.","user_interaction":"required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:H/SA:N","version":"4.0"},"cwes":[{"id":"CWE-841","name":"Improper Enforcement of Behavioral Workflow"},{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"},{"id":"CWE-288","name":"Authentication Bypass Using an Alternate Path or Channel"}],"description":"Fides is an open-source privacy engineering platform. From 2.75.0 to before 2.83.2, Fides deployments that enable both subject identity verification and duplicate privacy request detection are affected by a vulnerability in which an administrator can approve a privacy request whose identity was never verified. For erasure policies, this can result in unauthorized deletion of a data subject's records across every integration configured in the affected deployment. This vulnerability is fixed in 2.83.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Fides: Privacy Request Identity Verification Bypass Vulnerability via Duplicate Detection","id":"CVE-2026-42303","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"business_logic","year":"2026"},"n_packages":3,"n_references":6,"next":{"headline":"Twisted: Denial of Service (DoS) in twisted.names via Crafted DNS Compression Pointer Chains","id":"CVE-2026-42304"},"packages":[{"ecosystem":"PyPI","fixed":["2.83.2"],"introduced":["2.75.0"],"last_affected":[],"package":"ethyca-fides","purl":null,"source":"GHSA-qx5f-ghc2-7g5c"},{"ecosystem":"PyPI","fixed":["2.83.2"],"introduced":["2.75.0"],"last_affected":[],"package":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","source":"GHSA-qx5f-ghc2-7g5c"},{"ecosystem":"PyPI","fixed":["2.83.2"],"introduced":["2.75.0"],"last_affected":[],"package":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","source":"PYSEC-2026-2471"}],"prev":{"headline":"FastGPT: Unauthenticated Remote Code Execution (RCE) via code-server Misconfiguration in agent-sandbox","id":"CVE-2026-42302"},"products":["fides"],"published":"2026-05-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-12","vendors":["ethyca"]},"summary":"Attackers can bypass identity verification to approve privacy requests, leading to unauthorized data deletion in Fides deployments with specific features enabled.","url":"https://insights.sbomify.com/CVE-2026-42303/"}