# CVE-2026-42303: Fides: Privacy Request Identity Verification Bypass Vulnerability via Duplicate Detection

> Attackers can bypass identity verification to approve privacy requests, leading to unauthorized data deletion in Fides deployments with specific features enabled.

- **Severity:** Medium 6.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-qx5f-ghc2-7g5c, PYSEC-2026-2471

## What is CVE-2026-42303?

CVE-2026-42303 is a medium-severity vulnerability in ethyca fides, published on 12 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Fides is an open-source privacy engineering platform. From 2.75.0 to before 2.83.2, Fides deployments that enable both subject identity verification and duplicate privacy request detection are affected by a vulnerability in which an administrator can approve a privacy request whose identity was never verified. For erasure policies, this can result in unauthorized deletion of a data subject's records across every integration configured in the affected deployment. This vulnerability is fixed in 2.83.2.

Weakness: CWE-841 (Improper Enforcement of Behavioral Workflow), CWE-306 (Missing Authentication for Critical Functionality), CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2026-42303?

3 open source packages ship an affected version, including ethyca-fides.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | From 2.75.0 | 2.83.2 |
| `ethyca-fides` | PyPI | From 2.75.0 | 2.83.2 |
| `ethyca-fides` | PyPI | From 2.75.0 | 2.83.2 |

## How do I fix CVE-2026-42303?

Upgrade ethyca-fides to 2.83.2 or later.

## Is CVE-2026-42303 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42303 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42303 and fix it if it is affected.

What it is: CVE-2026-42303 is a medium-severity vulnerability in ethyca fides, published on 12 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42303 exists.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected from 2.75.0; fixed in 2.83.2
- ethyca-fides (PyPI): affected from 2.75.0; fixed in 2.83.2
- ethyca-fides (PyPI): affected from 2.75.0; fixed in 2.83.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42303/ (Markdown: https://insights.sbomify.com/CVE-2026-42303/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42303
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42303
- OSV: https://osv.dev/vulnerability/CVE-2026-42303

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42303/
Summaries are generated and may contain mistakes; the official description above is the record.
