# CVE-2026-42304: Twisted: Denial of Service (DoS) in twisted.names via Crafted DNS Compression Pointer Chains

> Remote attackers can cause denial of service in Twisted applications by sending crafted DNS packets that trigger resource exhaustion during name decompression.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 14 May 2026
- **Also known as:** AZL-86751, BELL-CVE-2026-42304, CLEANSTART-2026-FF58262, CLEANSTART-2026-XG33120, DEBIAN-CVE-2026-42304, GHSA-grgv-6hw6-v9g4, OESA-2026-2367, OESA-2026-2368, OESA-2026-2369, OESA-2026-2370, OESA-2026-2488, PYSEC-2026-160, SUSE-SU-2026:22004-1, SUSE-SU-2026:2218-1, SUSE-SU-2026:2219-1, UBUNTU-CVE-2026-42304, USN-8380-1, openSUSE-SU-2026:10759-1, openSUSE-SU-2026:20862-1

## What is CVE-2026-42304?

CVE-2026-42304 is a high-severity denial of service vulnerability in twisted, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Twisted is an event-based framework for internet applications, supporting Python 3.6+. Prior to 26.4.0rc2, the twisted.names module is vulnerable to a Denial of Service (DoS) attack via resource exhaustion during DNS name decompression. A remote, unauthenticated attacker can exploit this by sending a crafted TCP DNS packet containing deeply chained compression pointers. This flaw bypasses previous loop-prevention logic, causing the single-threaded Twisted reactor to hang while processing millions of recursive lookups, effectively freezing the server. This vulnerability is fixed in 26.4.0rc2.

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-42304?

3 open source packages ship an affected version, including twisted and Twisted. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twisted` | PyPI | All versions | 26.4.0 |
| `twisted` | PyPI | All versions | 26.4.0rc2 |
| `Twisted` | PyPI | All versions | 26.4.0rc2 |
| `python-Twisted` | SUSE:Linux Enterprise Server 16.0 | All versions | 24.10.0-160000.3.1 |
| `python-Twisted` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 24.10.0-160000.3.1 |
| `python-Twisted` | openSUSE:Tumbleweed | All versions | 26.4.0-1.1 |

Products: Twisted Twisted.

## How do I fix CVE-2026-42304?

Upgrade twisted to a fixed version for your release line: 26.4.0 or 26.4.0rc2.

## Is CVE-2026-42304 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42304 exists.

## Other vulnerabilities in twisted

- [CVE-2014-7143](https://insights.sbomify.com/CVE-2014-7143/): Python Twisted trustRoot is not respected in HTTP client (high 7.5)
- [CVE-2019-12855](https://insights.sbomify.com/CVE-2019-12855/): Improper Certificate Validation in Twisted (high 7.4)
- [CVE-2024-41810](https://insights.sbomify.com/CVE-2024-41810/): HTML injection in HTTP redirect body (medium 6.1)
- [CVE-2023-46137](https://insights.sbomify.com/CVE-2023-46137/): twisted.web has disordered HTTP pipeline response (medium 5.3)
- [CVE-2016-1000111](https://insights.sbomify.com/CVE-2016-1000111/): Forced Browsing in Twisted (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42304 and fix it if it is affected.

What it is: CVE-2026-42304 is a high-severity denial of service vulnerability in twisted, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42304 exists.

Affected packages and fixed versions:
- twisted (PyPI): affected all versions; fixed in 26.4.0
- twisted (PyPI): affected all versions; fixed in 26.4.0rc2
- Twisted (PyPI): affected all versions; fixed in 26.4.0rc2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42304/ (Markdown: https://insights.sbomify.com/CVE-2026-42304/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42304
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42304
- OSV: https://osv.dev/vulnerability/CVE-2026-42304

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42304/
Summaries are generated and may contain mistakes; the official description above is the record.
