# CVE-2026-42305: Dulwich has an arbitrary file write via NTFS-hostile tree entries on Windows

> Attackers can achieve remote code execution on Windows by tricking users into cloning malicious Git repositories using the Dulwich library.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** AZL-90074, CLEANSTART-2026-QB74422, CLSA-2026-1781225617, CLSA-2026-1791190774, ECHO-89fa-d0fd-2f03, GHSA-897w-fcg9-f6xj, MINI-fc3v-8vj4-4vv8, PYSEC-2026-2463, ROOT-APP-PYPI-CVE-2026-42305, UBUNTU-CVE-2026-42305

## What is CVE-2026-42305?

CVE-2026-42305 is a high-severity path traversal vulnerability in jelmer dulwich, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Dulwich is a pure-Python implementation of the Git file formats and protocols. Versions starting with 0.10.0 and prior to 1.2.5 have an arbitrary file write leading to remote code execution when cloning or checking out a malicious Git repository on Windows. Dulwich's path-element validator accepted tree entries whose filenames contained bytes that Windows interprets as structural path syntax. Contributing configuration bugs made matters worse. The core.protectNTFS and core.protectHFS settings were looked up under a wrong option name and so user-set values were silently ignored, and core.protectNTFS only defaulted to true on Windows (Git upstream has defaulted it to true everywhere since CVE-2019-1353). Both have been corrected. Anyone who clones, fetches, or checks out an untrusted repository with Dulwich on Windows - either through the Dulwich CLI, porcelain.clone, or any downstream tool built on Dulwich - is impacted. POSIX clones are not directly exploitable (on POSIX \ is a literal filename byte), but a POSIX user can unknowingly propagate a malicious tree to Windows consumers via push or re-publication. This issue is fixed in Dulwich 1.2.5. Users should upgrade to 1.2.5 or later. There is no effective pre-patch workaround. On affected versions the core.protectNTFS configuration key was silently ignored, so setting it to true does not mitigate the issue. Users who cannot upgrade should avoid cloning, fetching, or checking out untrusted repositories with Dulwich on Windows. After upgrading the NTFS validator is on by default on every platform, so no additional configuration is required.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-42305?

3 open source packages ship an affected version, including dulwich.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dulwich` | PyPI | From 0.10.0 | 1.2.5 |
| `dulwich` | PyPI | From 0.10.0 | 1.2.5 |
| `dulwich` | PyPI | From 0.10.0 | 1.2.5 |

## How do I fix CVE-2026-42305?

Upgrade dulwich to 1.2.5 or later.

## Is CVE-2026-42305 being exploited?

There is no known exploitation of CVE-2026-42305 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42305 and fix it if it is affected.

What it is: CVE-2026-42305 is a high-severity path traversal vulnerability in jelmer dulwich, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42305 in the wild and no public exploit code.

Affected packages and fixed versions:
- dulwich (PyPI): affected from 0.10.0; fixed in 1.2.5
- dulwich (PyPI): affected from 0.10.0; fixed in 1.2.5
- dulwich (PyPI): affected from 0.10.0; fixed in 1.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42305/ (Markdown: https://insights.sbomify.com/CVE-2026-42305/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42305
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42305
- OSV: https://osv.dev/vulnerability/CVE-2026-42305

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42305/
Summaries are generated and may contain mistakes; the official description above is the record.
