# CVE-2026-42308: Pillow: Integer overflow when processing fonts

> An attacker can cause a denial of service in applications using Pillow by providing a font with excessively large glyph advances, triggering an integer overflow.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2026
- **Updated:** 11 May 2026
- **Also known as:** BIT-pillow-2026-42308, CLEANSTART-2026-GE72398, CLEANSTART-2026-YZ67479, DEBIAN-CVE-2026-42308, ECHO-784c-565e-18bc, GHSA-wjx4-4jcj-g98j, MINI-3j8h-7ff7-7r92, MINI-6p98-83p8-3q7p, MINI-7pfc-x9r6-g9wf, MINI-f3hm-jh4j-f8m3, MINI-wgh8-x9xm-4w7f, PYSEC-2026-165, ROOT-APP-PYPI-CVE-2026-42308, SUSE-SU-2026:2004-1, UBUNTU-CVE-2026-42308

## What is CVE-2026-42308?

CVE-2026-42308 is a medium-severity vulnerability in Python Pillow, published on 9 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Pillow is a Python imaging library. Prior to version 12.2.0, if a font advances for each glyph by an exceeding large amount, when Pillow keeps track of the current position, it may lead to an integer overflow. This issue has been patched in version 12.2.0.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-42308?

4 open source packages ship an affected version, including pillow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | All versions | 12.2.0 |
| `pillow` | PyPI | All versions | 12.2.0 |
| `pillow` | PyPI | All versions | 12.2.0 |
| `pillow` | PyPI | All versions | 12.2.0 |

Products: Python Pillow.

## How do I fix CVE-2026-42308?

Upgrade pillow to 12.2.0 or later.

## Is CVE-2026-42308 being exploited?

There is no known exploitation of CVE-2026-42308 in the wild and no public exploit code.

## Other vulnerabilities in Python Pillow

- [CVE-2014-3007](https://insights.sbomify.com/CVE-2014-3007/): Pillow command injection (critical 10.0)
- [CVE-2026-96639](https://insights.sbomify.com/CVE-2026-96639/): Pillow multi-frame loaders can reuse stale native image storage after mode transitions (critical 9.8)
- [CVE-2022-30595](https://insights.sbomify.com/CVE-2022-30595/): Buffer over-flow in Pillow (critical 9.8)
- [CVE-2021-25289](https://insights.sbomify.com/CVE-2021-25289/): Out of bounds write in Pillow (critical 9.8)
- [CVE-2016-4009](https://insights.sbomify.com/CVE-2016-4009/): Pillow Integer overflow in ImagingResampleHorizontal (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42308 and fix it if it is affected.

What it is: CVE-2026-42308 is a medium-severity vulnerability in Python Pillow, published on 9 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42308 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (Bitnami): affected all versions; fixed in 12.2.0
- pillow (PyPI): affected all versions; fixed in 12.2.0
- pillow (PyPI): affected all versions; fixed in 12.2.0
- pillow (PyPI): affected all versions; fixed in 12.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42308/ (Markdown: https://insights.sbomify.com/CVE-2026-42308/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42308
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42308
- OSV: https://osv.dev/vulnerability/CVE-2026-42308

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42308/
Summaries are generated and may contain mistakes; the official description above is the record.
