# CVE-2026-42311: Pillow: OOB Write with Invalid PSD Tile Extents (Integer Overflow)

> Attackers can trigger memory corruption and potential code execution by processing malicious PSD files in the Pillow library.

- **Severity:** High 8.6 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2026
- **Updated:** 12 May 2026
- **Also known as:** BIT-pillow-2026-42311, CLEANSTART-2026-AG94767, CLEANSTART-2026-FR04537, CLSA-2026-1787244054, CLSA-2026-1790154692, CLSA-2026-1790239705, DEBIAN-CVE-2026-42311, ECHO-4895-da6a-8b1f, GHSA-pwv6-vv43-88gr, MINI-6chc-2cpw-qg9w, MINI-c944-x6f3-g655, MINI-jxq6-2h85-7p5p, MINI-mjf5-8f9c-v35v, MINI-qv6q-fv83-8732, MINI-wfj2-fp5c-mvvj, MINI-wx7q-w6m2-6236, OESA-2026-2428, OESA-2026-2429, PYSEC-2026-2252, ROOT-APP-PYPI-CVE-2026-42311, UBUNTU-CVE-2026-42311

## What is CVE-2026-42311?

CVE-2026-42311 is a high-severity vulnerability in Python Pillow, published on 9 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Pillow is a Python imaging library. From version 10.3.0 to before version 12.2.0, processing a malicious PSD file could lead to memory corruption, potentially resulting in a crash or arbitrary code execution. This issue has been patched in version 12.2.0.

Weakness: CWE-787 (Out-of-bounds Write), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-42311?

4 open source packages ship an affected version, including pillow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | From 10.3.0 | 12.2.0 |
| `pillow` | PyPI | From 10.3.0 | 12.2.0 |
| `pillow` | PyPI | From 10.3.0 | 12.2.0 |
| `pillow` | PyPI | From 10.3.0 | 12.2.0 |

Products: Python Pillow.

## How do I fix CVE-2026-42311?

Upgrade pillow to 12.2.0 or later.

## Is CVE-2026-42311 being exploited?

There is no known exploitation of CVE-2026-42311 in the wild and no public exploit code.

## Other vulnerabilities in Python Pillow

- [CVE-2014-3007](https://insights.sbomify.com/CVE-2014-3007/): Pillow command injection (critical 10.0)
- [CVE-2026-96639](https://insights.sbomify.com/CVE-2026-96639/): Pillow multi-frame loaders can reuse stale native image storage after mode transitions (critical 9.8)
- [CVE-2022-30595](https://insights.sbomify.com/CVE-2022-30595/): Buffer over-flow in Pillow (critical 9.8)
- [CVE-2021-25289](https://insights.sbomify.com/CVE-2021-25289/): Out of bounds write in Pillow (critical 9.8)
- [CVE-2016-4009](https://insights.sbomify.com/CVE-2016-4009/): Pillow Integer overflow in ImagingResampleHorizontal (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42311 and fix it if it is affected.

What it is: CVE-2026-42311 is a high-severity vulnerability in Python Pillow, published on 9 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42311 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (Bitnami): affected from 10.3.0; fixed in 12.2.0
- pillow (PyPI): affected from 10.3.0; fixed in 12.2.0
- pillow (PyPI): affected from 10.3.0; fixed in 12.2.0
- pillow (PyPI): affected from 10.3.0; fixed in 12.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42311/ (Markdown: https://insights.sbomify.com/CVE-2026-42311/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42311
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42311
- OSV: https://osv.dev/vulnerability/CVE-2026-42311

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42311/
Summaries are generated and may contain mistakes; the official description above is the record.
