# CVE-2026-42313: pyload-ng: non-admin SETTINGS users can redirect all outbound traffic through an attacker-controlled proxy

> Authenticated non-admin users can configure proxy settings to route all outbound traffic through an attacker-controlled server, enabling data interception.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-pg67-9wjv-mr85, PYSEC-2026-127

## What is CVE-2026-42313?

CVE-2026-42313 is a high-severity server-side request forgery vulnerability in pyload, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pyLoad is a free and open-source download manager written in Python. Prior to 0.5.0b3.dev100, the set_config_value() API method (@permission(Perms.SETTINGS)) in src/pyload/core/api/__init__.py gates security-sensitive options behind a hand-maintained allowlist ADMIN_ONLY_CORE_OPTIONS. The allowlist contains ("proxy", "username") and ("proxy", "password") — which protect the proxy credentials — but it does not include ("proxy", "enabled"), ("proxy", "host"), ("proxy", "port"), or ("proxy", "type"). Any authenticated user with the non-admin SETTINGS permission can enable proxying and point pyload at any host they control. From that point, every outbound download, captcha fetch, update check, and plugin HTTP call is transparently routed through the attacker. This is a direct continuation of the fix family CVE-2026-33509 / CVE-2026-35463 / CVE-2026-35464 / CVE-2026-35586, each of which patched a different missed option in the same allowlist. This vulnerability is fixed in 0.5.0b3.dev100.

Weakness: CWE-863 (Incorrect Authorization), CWE-918 (Server-Side Request Forgery), CWE-441 (Unintended Proxy or Intermediary)

## Which versions are affected by CVE-2026-42313?

3 open source packages ship an affected version, including pyload-ng. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev100 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev100 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev100 |

Products: Pyload-Ng Project Pyload-Ng.

## How do I fix CVE-2026-42313?

Upgrade pyload-ng to 0.5.0b3.dev100 or later.

## Is CVE-2026-42313 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42313 exists.

## Other vulnerabilities in pyload

- [CVE-2025-54802](https://insights.sbomify.com/CVE-2025-54802/): pyLoad CNL Blueprint is vulnerable to Path Traversal through `dlc_path` leading to Remote Code Execution (RCE) (critical 9.8)
- [CVE-2024-22416](https://insights.sbomify.com/CVE-2024-22416/): Cross-Site Request Forgery on any API call in pyLoad may lead to admin privilege escalation (critical 9.7)
- [CVE-2023-0488](https://insights.sbomify.com/CVE-2023-0488/): Cross-site Scripting (XSS) - Stored in pyload/pyload (critical 9.6)
- [CVE-2026-35459](https://insights.sbomify.com/CVE-2026-35459/): pyLoad has SSRF fix bypass via HTTP redirect (critical 9.3)
- [CVE-2026-35463](https://insights.sbomify.com/CVE-2026-35463/): pyLoad has Improper Neutralization of Special Elements used in an OS Command (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42313 and fix it if it is affected.

What it is: CVE-2026-42313 is a high-severity server-side request forgery vulnerability in pyload, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42313 exists.

Affected packages and fixed versions:
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev100
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev100
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev100

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42313/ (Markdown: https://insights.sbomify.com/CVE-2026-42313/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42313
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42313
- OSV: https://osv.dev/vulnerability/CVE-2026-42313

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42313/
Summaries are generated and may contain mistakes; the official description above is the record.
