CVE-2026-42317 GLPI vulnerable to arbitrary files deletion by technician
A technician can delete arbitrary files from the filesystem if the webserver has write permissions, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-42317?
CVE-2026-42317 is a high-severity missing authorization vulnerability in glpi-project glpi, published on 3 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
GLPI is a free asset and IT management software package. Starting in version 0.78 and prior to versions 10.0.25 and 11.0.7, a technician can delete arbitrary files from the filesystem as long as the webserver has write rights on them. Upgrade to 10.0.25 or 11.0.7 to receive a patch.
Weakness: CWE-862
Which versions are affected by CVE-2026-42317?
How do I fix CVE-2026-42317?
No fix has been published for CVE-2026-42317 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-42317 being exploited?
There is no known exploitation of CVE-2026-42317 in the wild and no public exploit code.
Sources
Also known as GHSA-jf72-cvjh-px5w, UBUNTU-CVE-2026-42317.