CVE-2026-42318 GLPI Vulnerable to Arbitrary Item Deletion via Planning Endpoint
Low-privilege users can delete arbitrary objects in GLPI due to missing authorization checks in the planning endpoint.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-42318?
CVE-2026-42318 is a high-severity missing authorization vulnerability in glpi-project glpi, published on 3 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
GLPI is a free asset and IT management software package. Starting in version 9.5.0 and prior to versions 10.0.25 and 11.0.7, low privilege users with access to planning can delete any object in GLPI. Upgrade to 11.0.7 or 10.0.25 to receive a patch. As a workaround, disable delete rights for User's planning.
Weakness: CWE-862
Which versions are affected by CVE-2026-42318?
How do I fix CVE-2026-42318?
No fix has been published for CVE-2026-42318 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-42318 being exploited?
There is no known exploitation of CVE-2026-42318 in the wild and no public exploit code.
Sources
Also known as GHSA-w7mr-3vwm-2j22, UBUNTU-CVE-2026-42318.