# CVE-2026-42318: GLPI Vulnerable to Arbitrary Item Deletion via Planning Endpoint

> Low-privilege users can delete arbitrary objects in GLPI due to missing authorization checks in the planning endpoint.

- **Severity:** High 7.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Jun 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-w7mr-3vwm-2j22, UBUNTU-CVE-2026-42318

## What is CVE-2026-42318?

CVE-2026-42318 is a high-severity missing authorization vulnerability in glpi-project glpi, published on 3 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

GLPI is a free asset and IT management software package. Starting in version 9.5.0 and prior to versions 10.0.25 and 11.0.7, low privilege users with access to planning can delete any object in GLPI. Upgrade to 11.0.7 or 10.0.25 to receive a patch. As a workaround, disable delete rights for User's planning.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-42318?


## How do I fix CVE-2026-42318?

No fix has been published for CVE-2026-42318 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42318 being exploited?

There is no known exploitation of CVE-2026-42318 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42318 and fix it if it is affected.

What it is: CVE-2026-42318 is a high-severity missing authorization vulnerability in glpi-project glpi, published on 3 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42318 in the wild and no public exploit code.

Affected product: glpi-project glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42318/ (Markdown: https://insights.sbomify.com/CVE-2026-42318/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42318
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42318
- OSV: https://osv.dev/vulnerability/CVE-2026-42318

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42318/
Summaries are generated and may contain mistakes; the official description above is the record.
