# CVE-2026-42320: GLPI vulnerable to arbitrary file access

> A technician can read arbitrary files within the document directory, exposing sensitive data in GLPI IT management software.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Jun 2026
- **Updated:** 3 Jun 2026
- **Also known as:** GHSA-58j6-94cf-gcx5, UBUNTU-CVE-2026-42320

## What is CVE-2026-42320?

CVE-2026-42320 is a medium-severity path traversal vulnerability in glpi-project glpi, published on 3 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

GLPI is a free asset and IT management software package. Starting in version 0.50 and prior to versions 10.0.25 and 11.0.7, a technician can read arbitrary files inside the GLPI_DOC_DIR. Upgrade to 10.0.25 or 11.0.7 to receive a patch.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-42320?


## How do I fix CVE-2026-42320?

No fix has been published for CVE-2026-42320 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42320 being exploited?

There is no known exploitation of CVE-2026-42320 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42320 and fix it if it is affected.

What it is: CVE-2026-42320 is a medium-severity path traversal vulnerability in glpi-project glpi, published on 3 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42320 in the wild and no public exploit code.

Affected product: glpi-project glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42320/ (Markdown: https://insights.sbomify.com/CVE-2026-42320/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42320
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42320
- OSV: https://osv.dev/vulnerability/CVE-2026-42320

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42320/
Summaries are generated and may contain mistakes; the official description above is the record.
