CVE-2026-42321 GLPI has stored XSS in asset locks
A technician can inject stored XSS payloads in the asset locked tab, potentially leading to code execution or account takeover.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2026-42321?
CVE-2026-42321 is a high-severity cross-site scripting vulnerability in glpi-project glpi, published on 3 Jun 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
GLPI is a free asset and IT management software package. Starting in version 10.0.4 and prior to version 10.0.25, a technician can store an XSS payload in the asset locked tab. Upgrade to 10.0.25 or 11.0.7 to receive a patch.
Which versions are affected by CVE-2026-42321?
How do I fix CVE-2026-42321?
No fix has been published for CVE-2026-42321 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-42321 being exploited?
There is no known exploitation of CVE-2026-42321 in the wild and no public exploit code.
Sources
Also known as GHSA-hwjc-8228-55x4, UBUNTU-CVE-2026-42321.