# CVE-2026-42321: GLPI has stored XSS in asset locks

> A technician can inject stored XSS payloads in the asset locked tab, potentially leading to code execution or account takeover.

- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 3 Jun 2026
- **Updated:** 3 Jun 2026
- **Also known as:** GHSA-hwjc-8228-55x4, UBUNTU-CVE-2026-42321

## What is CVE-2026-42321?

CVE-2026-42321 is a high-severity cross-site scripting vulnerability in glpi-project glpi, published on 3 Jun 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

GLPI is a free asset and IT management software package. Starting in version 10.0.4 and prior to version 10.0.25, a technician can store an XSS payload in the asset locked tab. Upgrade to 10.0.25 or 11.0.7 to receive a patch.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-42321?


## How do I fix CVE-2026-42321?

No fix has been published for CVE-2026-42321 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42321 being exploited?

There is no known exploitation of CVE-2026-42321 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42321 and fix it if it is affected.

What it is: CVE-2026-42321 is a high-severity cross-site scripting vulnerability in glpi-project glpi, published on 3 Jun 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42321 in the wild and no public exploit code.

Affected product: glpi-project glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42321/ (Markdown: https://insights.sbomify.com/CVE-2026-42321/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42321
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42321
- OSV: https://osv.dev/vulnerability/CVE-2026-42321

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42321/
Summaries are generated and may contain mistakes; the official description above is the record.
