{"answers":{"affected":"2 open source packages ship an affected version, including openssl.","exploited":"There is no known exploitation of CVE-2026-42327 in the wild and no public exploit code.","fix":"Upgrade openssl to 0.10.79 or later.","what":"CVE-2026-42327 is a high-severity memory corruption vulnerability in rust-openssl, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42327 and fix it if it is affected.\n\nWhat it is: CVE-2026-42327 is a high-severity memory corruption vulnerability in rust-openssl, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42327 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openssl (crates.io): affected from 0.9.7; fixed in 0.10.79\n- openssl (crates.io): affected from 0.9.7; fixed in 0.10.79\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42327/ (Markdown: https://insights.sbomify.com/CVE-2026-42327/index.md)","id":"CVE-2026-42327","markdown":"https://insights.sbomify.com/CVE-2026-42327/index.md","name":"CVE-2026-42327","record":{"aliases":["DEBIAN-CVE-2026-42327","GHSA-xp3w-r5p5-63rr","MINI-3g7w-6vr9-65pc","MINI-4w5m-cfp6-xgrx","MINI-8r87-6f22-3x29","MINI-fj2c-w9hh-m5wq","MINI-hvfp-4hx8-vc2x","MINI-pgv3-vqrm-rw4g","MINI-qq7q-xv92-fmjp","MINI-rpvm-2hrc-7cq7","MINI-vvrf-r46r-h85f","UBUNTU-CVE-2026-42327"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust OpenSSL bindings","requires_auth":"none","summary":"Attackers can trigger undefined behavior in rust-openssl by providing certificates with non-UTF-8 OCSP URLs, potentially leading to crashes or code execution.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.7 to before 0.10.79, X509Ref::ocsp_responders returns OCSP responder URLs from a certificate's AIA extension as OpensslString, whose Deref\u003cTarget = str\u003e wraps the raw bytes with str::from_utf8_unchecked. OpenSSL does not enforce that the underlying IA5String is ASCII, so a certificate with non-UTF-8 bytes in its OCSP accessLocation causes safe Rust code to construct a \u0026str that violates the UTF-8 invariant — resulting in undefined behavior. This vulnerability is fixed in 0.10.79.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"rust-openssl: undefined behavior in X509Ref::ocsp_responders for certificates with non-UTF-8 OCSP URLs","id":"CVE-2026-42327","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"go-ipld-prime: DAG-CBOR and DAG-JSON decoders unbounded recursion depth","id":"CVE-2026-42328"},"packages":[{"ecosystem":"crates.io","fixed":["0.10.79"],"introduced":["0.9.7"],"last_affected":[],"package":"openssl","purl":null,"source":"GHSA-xp3w-r5p5-63rr"},{"ecosystem":"crates.io","fixed":["0.10.79"],"introduced":["0.9.7"],"last_affected":[],"package":"openssl","purl":"pkg:cargo/openssl","source":"GHSA-xp3w-r5p5-63rr"}],"prev":{"headline":"ImageMagick: Heap Buffer Over-Read in IPTC encoder","id":"CVE-2026-42326"},"products":["rust-openssl"],"published":"2026-05-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-15","vendors":["rust-openssl"]},"summary":"Attackers can trigger undefined behavior in rust-openssl by providing certificates with non-UTF-8 OCSP URLs, potentially leading to crashes or code execution.","url":"https://insights.sbomify.com/CVE-2026-42327/"}