{"answers":{"affected":"3 open source packages ship an affected version, including github.com/ipld/go-ipld-prime.","exploited":"There is no known exploitation of CVE-2026-42328 in the wild and no public exploit code.","fix":"Upgrade github.com/ipld/go-ipld-prime to 0.23.0 or later.","what":"CVE-2026-42328 is a medium-severity denial of service vulnerability in go-ipld-prime, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42328 and fix it if it is affected.\n\nWhat it is: CVE-2026-42328 is a medium-severity denial of service vulnerability in go-ipld-prime, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42328 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/ipld/go-ipld-prime (Go): affected all versions; fixed in 0.23.0\n- github.com/ipld/go-ipld-prime (Go): affected all versions; fixed in 0.23.0\n- github.com/ipld/go-ipld-prime (Go): affected all versions; fixed in 0.23.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42328/ (Markdown: https://insights.sbomify.com/CVE-2026-42328/index.md)","id":"CVE-2026-42328","markdown":"https://insights.sbomify.com/CVE-2026-42328/index.md","name":"CVE-2026-42328","record":{"aliases":["GHSA-w239-58x2-q8p5","GO-2026-5684","MINI-456h-qq37-p46f","MINI-xmh3-45pm-pfwf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Go IPLD library","requires_auth":"none","summary":"Attackers can cause a denial of service by sending deeply nested data to the go-ipld-prime decoders, crashing the application via stack overflow.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"go-ipld-prime is an implementation of the InterPlanetary Linked Data (IPLD) spec interfaces, a batteries-included codec implementations of IPLD for CBOR and JSON, and tooling for basic operations on IPLD objects. Prior to 0.23.0, the DAG-CBOR and DAG-JSON decoders recurse on each nested map or list without a depth limit. A payload containing deeply nested collections causes the decoder to recurse once per level, growing the goroutine stack until the Go runtime terminates the process with a fatal stack overflow (distinct from a recoverable panic). This vulnerability is fixed in 0.23.0.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"go-ipld-prime: DAG-CBOR and DAG-JSON decoders unbounded recursion depth","id":"CVE-2026-42328","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Iris has an Open Redirect issue","id":"CVE-2026-42329"},"packages":[{"ecosystem":"Go","fixed":["0.23.0"],"introduced":["0"],"last_affected":[],"package":"github.com/ipld/go-ipld-prime","purl":null,"source":"GHSA-w239-58x2-q8p5"},{"ecosystem":"Go","fixed":["0.23.0"],"introduced":["0"],"last_affected":[],"package":"github.com/ipld/go-ipld-prime","purl":"pkg:golang/github.com/ipld/go-ipld-prime","source":"GHSA-w239-58x2-q8p5"},{"ecosystem":"Go","fixed":["0.23.0"],"introduced":["0"],"last_affected":[],"package":"github.com/ipld/go-ipld-prime","purl":"pkg:golang/github.com/ipld/go-ipld-prime","source":"GO-2026-5684"}],"prev":{"headline":"rust-openssl: undefined behavior in X509Ref::ocsp_responders for certificates with non-UTF-8 OCSP URLs","id":"CVE-2026-42327"},"products":["go-ipld-prime"],"published":"2026-05-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-28","vendors":["ipld"]},"summary":"Attackers can cause a denial of service by sending deeply nested data to the go-ipld-prime decoders, crashing the application via stack overflow.","url":"https://insights.sbomify.com/CVE-2026-42328/"}