# CVE-2026-42335: MaxKB: SSRF Bypass in MaxKB OSS URL Fetch due to URL Parsing Discrepancy

> Attackers can bypass URL validation to access internal network services via the OSS file service endpoint in MaxKB.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-r8hf-mwwr-hxgc

## What is CVE-2026-42335?

CVE-2026-42335 is a medium-severity server-side request forgery vulnerability in 1Panel-dev MaxKB, published on 26 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MaxKB is an open-source AI assistant for enterprise. Prior to 2.8.1, MaxKB v2.8.0 and prior are vulnerable to a server-side request forgery (SSRF) bypass in the OSS file service URL fetch (chat/api/oss/get_url) endpoint. The vulnerability exists due to inconsistent URL parsing between the urlparse validation function and the requests HTTP client, allowing attackers to access internal network services. This vulnerability is fixed in 2.8.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-42335?


## How do I fix CVE-2026-42335?

No fix has been published for CVE-2026-42335 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42335 being exploited?

There is no known exploitation of CVE-2026-42335 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42335 and fix it if it is affected.

What it is: CVE-2026-42335 is a medium-severity server-side request forgery vulnerability in 1Panel-dev MaxKB, published on 26 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42335 in the wild and no public exploit code.

Affected product: 1Panel-dev MaxKB. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42335/ (Markdown: https://insights.sbomify.com/CVE-2026-42335/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42335
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42335
- OSV: https://osv.dev/vulnerability/CVE-2026-42335

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42335/
Summaries are generated and may contain mistakes; the official description above is the record.
