# CVE-2026-42337: MaxKB: Broken Access Control in MaxKB OSS URL Fetch API

> Attackers can access or modify other applications' data via the OSS URL fetch API due to missing ownership validation.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-2jmj-gwvg-3gp2

## What is CVE-2026-42337?

CVE-2026-42337 is a medium-severity missing authorization vulnerability in 1Panel-dev MaxKB, published on 26 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MaxKB is an open-source AI assistant for enterprise. MaxKB 2.8.0 and prior are vulnerable to a broken access control vulnerability in the OSS file service URL fetch API (chat/api/oss/get_url). The endpoint uses application_id from the URL path without validating ownership, allowing attackers to perform operations under other applications’ policies. This vulnerability is fixed in 2.8.1.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-42337?


## How do I fix CVE-2026-42337?

No fix has been published for CVE-2026-42337 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42337 being exploited?

There is no known exploitation of CVE-2026-42337 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42337 and fix it if it is affected.

What it is: CVE-2026-42337 is a medium-severity missing authorization vulnerability in 1Panel-dev MaxKB, published on 26 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42337 in the wild and no public exploit code.

Affected product: 1Panel-dev MaxKB. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42337/ (Markdown: https://insights.sbomify.com/CVE-2026-42337/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42337
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42337
- OSV: https://osv.dev/vulnerability/CVE-2026-42337

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42337/
Summaries are generated and may contain mistakes; the official description above is the record.
