CVE-2026-42352 pygeoapi 0.23.x: Unauthenticated SSRF via OGC API - Processes Subscriber
Unauthenticated attackers can exploit the subscriber object in OGC API process requests to access internal HTTP services, requiring an upgrade to pygeoapi.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42352?
CVE-2026-42352 is a high-severity server-side request forgery vulnerability in geopython pygeoapi, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
pygeoapi is a Python server implementation of the OGC API suite of standards. From version 0.23.0 to before version 0.23.3, OGC API process execution requests can use the subscriber object to requests to internal HTTP services. This issue has been patched in version 0.23.3.
Weakness: CWE-918
Which versions are affected by CVE-2026-42352?
3 open source packages ship an affected version, including pygeoapi.
| Package | Affected | Fixed in |
|---|---|---|
pygeoapi PyPI | From 0.23.0 | 0.23.3 |
pygeoapi PyPI | From 0.23.0 | 0.23.3 |
pygeoapi PyPI | From 0.23.0 | 0.23.3 |
How do I fix CVE-2026-42352?
Upgrade pygeoapi to 0.23.3 or later.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-42352 being exploited?
There is no known exploitation of CVE-2026-42352 in the wild and no public exploit code.
Sources
Also known as GHSA-jgvc-94c8-3chc, PYSEC-2026-2986.