{"answers":{"affected":"3 open source packages ship an affected version, including pygeoapi.","exploited":"There is no known exploitation of CVE-2026-42352 in the wild and no public exploit code.","fix":"Upgrade pygeoapi to 0.23.3 or later.","what":"CVE-2026-42352 is a high-severity server-side request forgery vulnerability in geopython pygeoapi, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42352 and fix it if it is affected.\n\nWhat it is: CVE-2026-42352 is a high-severity server-side request forgery vulnerability in geopython pygeoapi, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42352 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pygeoapi (PyPI): affected from 0.23.0; fixed in 0.23.3\n- pygeoapi (PyPI): affected from 0.23.0; fixed in 0.23.3\n- pygeoapi (PyPI): affected from 0.23.0; fixed in 0.23.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42352/ (Markdown: https://insights.sbomify.com/CVE-2026-42352/index.md)","id":"CVE-2026-42352","markdown":"https://insights.sbomify.com/CVE-2026-42352/index.md","name":"CVE-2026-42352","record":{"aliases":["GHSA-jgvc-94c8-3chc","PYSEC-2026-2986"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OGC API server","requires_auth":"none","summary":"Unauthenticated attackers can exploit the subscriber object in OGC API process requests to access internal HTTP services, requiring an upgrade to pygeoapi.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"pygeoapi is a Python server implementation of the OGC API suite of standards. From version 0.23.0 to before version 0.23.3, OGC API  process execution requests can use the subscriber object to requests to internal HTTP services. This issue has been patched in version 0.23.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pygeoapi 0.23.x: Unauthenticated SSRF via OGC API - Processes Subscriber","id":"CVE-2026-42352","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Path traversal / SSRF in i18next-http-middleware via user-controlled language and namespace parameters","id":"CVE-2026-42353"},"packages":[{"ecosystem":"PyPI","fixed":["0.23.3"],"introduced":["0.23.0"],"last_affected":[],"package":"pygeoapi","purl":null,"source":"GHSA-jgvc-94c8-3chc"},{"ecosystem":"PyPI","fixed":["0.23.3"],"introduced":["0.23.0"],"last_affected":[],"package":"pygeoapi","purl":"pkg:pypi/pygeoapi","source":"GHSA-jgvc-94c8-3chc"},{"ecosystem":"PyPI","fixed":["0.23.3"],"introduced":["0.23.0"],"last_affected":[],"package":"pygeoapi","purl":"pkg:pypi/pygeoapi","source":"PYSEC-2026-2986"}],"prev":{"headline":"pygeoapi: Path Traversal in STAC FileSystemProvider","id":"CVE-2026-42351"},"products":["pygeoapi"],"published":"2026-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-11","vendors":["geopython"]},"summary":"Unauthenticated attackers can exploit the subscriber object in OGC API process requests to access internal HTTP services, requiring an upgrade to pygeoapi.","url":"https://insights.sbomify.com/CVE-2026-42352/"}