{"answers":{"affected":"2 open source packages ship an affected version, including i18next-http-middleware.","exploited":"There is no known exploitation of CVE-2026-42353 in the wild and no public exploit code.","fix":"Upgrade i18next-http-middleware to 3.9.3 or later.","what":"CVE-2026-42353 is a high-severity path traversal vulnerability in i18next-http-middleware, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42353 and fix it if it is affected.\n\nWhat it is: CVE-2026-42353 is a high-severity path traversal vulnerability in i18next-http-middleware, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42353 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- i18next-http-middleware (npm): affected all versions; fixed in 3.9.3\n- i18next-http-middleware (npm): affected all versions; fixed in 3.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42353/ (Markdown: https://insights.sbomify.com/CVE-2026-42353/index.md)","id":"CVE-2026-42353","markdown":"https://insights.sbomify.com/CVE-2026-42353/index.md","name":"CVE-2026-42353","record":{"aliases":["GHSA-jfgf-83c5-2c4m"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js i18n middleware","requires_auth":"none","summary":"Attackers can exploit unsanitized language and namespace parameters to perform path traversal or SSRF, potentially reading sensitive files or accessing internal services.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"i18next-http-middleware is a middleware to be used with Node.js web frameworks like express or Fastify and also for Deno. Prior to version 3.9.3, i18next-http-middleware passes the user-controlled lng and ns values from getResourcesHandler directly into i18next.services.backendConnector.load(languages, namespaces, …) without any sanitization. Depending on which backend is configured, the unvalidated path segments enable either path traversal or SSRF. This issue has been patched in version 3.9.3.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path traversal / SSRF in i18next-http-middleware via user-controlled language and namespace parameters","id":"CVE-2026-42353","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Sentry: Improper authentication on SAML SSO process allows user identity linking","id":"CVE-2026-42354"},"packages":[{"ecosystem":"npm","fixed":["3.9.3"],"introduced":["0"],"last_affected":[],"package":"i18next-http-middleware","purl":null,"source":"GHSA-jfgf-83c5-2c4m"},{"ecosystem":"npm","fixed":["3.9.3"],"introduced":["0"],"last_affected":[],"package":"i18next-http-middleware","purl":"pkg:npm/i18next-http-middleware","source":"GHSA-jfgf-83c5-2c4m"}],"prev":{"headline":"pygeoapi 0.23.x: Unauthenticated SSRF via OGC API - Processes Subscriber","id":"CVE-2026-42352"},"products":["i18next-http-middleware"],"published":"2026-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-08","vendors":["i18next"]},"summary":"Attackers can exploit unsanitized language and namespace parameters to perform path traversal or SSRF, potentially reading sensitive files or accessing internal services.","url":"https://insights.sbomify.com/CVE-2026-42353/"}