# CVE-2026-42353: Path traversal / SSRF in i18next-http-middleware via user-controlled language and namespace parameters

> Attackers can exploit unsanitized language and namespace parameters to perform path traversal or SSRF, potentially reading sensitive files or accessing internal services.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-jfgf-83c5-2c4m

## What is CVE-2026-42353?

CVE-2026-42353 is a high-severity path traversal vulnerability in i18next-http-middleware, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

i18next-http-middleware is a middleware to be used with Node.js web frameworks like express or Fastify and also for Deno. Prior to version 3.9.3, i18next-http-middleware passes the user-controlled lng and ns values from getResourcesHandler directly into i18next.services.backendConnector.load(languages, namespaces, …) without any sanitization. Depending on which backend is configured, the unvalidated path segments enable either path traversal or SSRF. This issue has been patched in version 3.9.3.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-42353?

2 open source packages ship an affected version, including i18next-http-middleware.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `i18next-http-middleware` | npm | All versions | 3.9.3 |
| `i18next-http-middleware` | npm | All versions | 3.9.3 |

## How do I fix CVE-2026-42353?

Upgrade i18next-http-middleware to 3.9.3 or later.

## Is CVE-2026-42353 being exploited?

There is no known exploitation of CVE-2026-42353 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42353 and fix it if it is affected.

What it is: CVE-2026-42353 is a high-severity path traversal vulnerability in i18next-http-middleware, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42353 in the wild and no public exploit code.

Affected packages and fixed versions:
- i18next-http-middleware (npm): affected all versions; fixed in 3.9.3
- i18next-http-middleware (npm): affected all versions; fixed in 3.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42353/ (Markdown: https://insights.sbomify.com/CVE-2026-42353/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42353
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42353
- OSV: https://osv.dev/vulnerability/CVE-2026-42353

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42353/
Summaries are generated and may contain mistakes; the official description above is the record.
