CVE-2026-42354 Sentry: Improper authentication on SAML SSO process allows user identity linking

Critical 9.1 Published Updated

Attackers can take over user accounts via malicious SAML SSO configuration if the victim's email is known.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-42354?

CVE-2026-42354 is a critical authentication bypass vulnerability in getsentry sentry, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Sentry is an error tracking and performance monitoring tool. From version 21.12.0 to before version 26.4.1, a critical vulnerability was discovered in the SAML SSO implementation of Sentry. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. This issue has been patched in version 26.4.1.

Weakness: CWE-290

Which versions are affected by CVE-2026-42354?

3 open source packages ship an affected version, including sentry. It affects 1 product.

PackageAffectedFixed in
sentry PyPIFrom 21.12.026.4.1
sentry PyPIFrom 21.12.026.4.1
sentry PyPIFrom 21.12.026.4.1

Products include Sentry Sentry.

How do I fix CVE-2026-42354?

Upgrade sentry to 26.4.1 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-42354 being exploited?

There is no known exploitation of CVE-2026-42354 in the wild and no public exploit code.

Sources

Also known as ECHO-ea50-90d1-d8b8, GHSA-rcmw-7mc7-3rj7, PYSEC-2026-534.

Is CVE-2026-42354 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free