# CVE-2026-42354: Sentry: Improper authentication on SAML SSO process allows user identity linking

> Attackers can take over user accounts via malicious SAML SSO configuration if the victim's email is known.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 11 May 2026
- **Also known as:** ECHO-ea50-90d1-d8b8, GHSA-rcmw-7mc7-3rj7, PYSEC-2026-534

## What is CVE-2026-42354?

CVE-2026-42354 is a critical authentication bypass vulnerability in getsentry sentry, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sentry is an error tracking and performance monitoring tool. From version 21.12.0 to before version 26.4.1, a critical vulnerability was discovered in the SAML SSO implementation of Sentry. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. This issue has been patched in version 26.4.1.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-42354?

3 open source packages ship an affected version, including sentry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sentry` | PyPI | From 21.12.0 | 26.4.1 |
| `sentry` | PyPI | From 21.12.0 | 26.4.1 |
| `sentry` | PyPI | From 21.12.0 | 26.4.1 |

Products: Sentry Sentry.

## How do I fix CVE-2026-42354?

Upgrade sentry to 26.4.1 or later.

## Is CVE-2026-42354 being exploited?

There is no known exploitation of CVE-2026-42354 in the wild and no public exploit code.

## Other vulnerabilities in getsentry sentry

- [CVE-2026-27197](https://insights.sbomify.com/CVE-2026-27197/): Sentry: Improper Authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2021-47935](https://insights.sbomify.com/CVE-2021-47935/): Sentry 8.2.0 Remote Code Execution via Pickle Deserialization (high 8.7)
- [CVE-2023-39349](https://insights.sbomify.com/CVE-2023-39349/): Sentry vulnerable to privilege escalation via ApiTokensEndpoint (high 8.1)
- [CVE-2023-36826](https://insights.sbomify.com/CVE-2023-36826/): Sentry vulnerable to improper authorization on debug and artifact file downloads (high 7.7)
- [CVE-2026-52794](https://insights.sbomify.com/CVE-2026-52794/): Sentry: Inefficient Regular Expression Complexity in sentry (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42354 and fix it if it is affected.

What it is: CVE-2026-42354 is a critical authentication bypass vulnerability in getsentry sentry, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42354 in the wild and no public exploit code.

Affected packages and fixed versions:
- sentry (PyPI): affected from 21.12.0; fixed in 26.4.1
- sentry (PyPI): affected from 21.12.0; fixed in 26.4.1
- sentry (PyPI): affected from 21.12.0; fixed in 26.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42354/ (Markdown: https://insights.sbomify.com/CVE-2026-42354/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42354
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42354
- OSV: https://osv.dev/vulnerability/CVE-2026-42354

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42354/
Summaries are generated and may contain mistakes; the official description above is the record.
