{"answers":{"affected":"1 open source package ship an affected version, including apache. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-42356 in the wild and no public exploit code.","fix":"Upgrade apache to 2.4.69 or later.","what":"CVE-2026-42356 is a low-severity code injection vulnerability in Apache Http Server, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42356 and fix it if it is affected.\n\nWhat it is: CVE-2026-42356 is a low-severity code injection vulnerability in Apache Http Server, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42356 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache (Bitnami): affected from 2.4.0; fixed in 2.4.69\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42356/ (Markdown: https://insights.sbomify.com/CVE-2026-42356/index.md)","id":"CVE-2026-42356","markdown":"https://insights.sbomify.com/CVE-2026-42356/index.md","name":"CVE-2026-42356","record":{"aliases":["ALPINE-CVE-2026-42356","AZL-106752","BELL-CVE-2026-42356","BIT-apache-2026-42356","CLSA-2026-1791881377","CLSA-2026-1791883129","CLSA-2026-1791886853","CLSA-2026-1791887095","DEBIAN-CVE-2026-42356","ECHO-8ed6-1d57-bbbb","GHSA-rxhx-8qf3-fc8h","MINI-vgqc-vpm6-pm37","UBUNTU-CVE-2026-42356"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache HTTP Server","requires_auth":"none","summary":"Attackers can execute arbitrary code via internal redirects to non-CGI files in CGI-enabled directories due to incorrect handler deployment.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"}],"cvss":{"score":3.7,"severity":"low","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-430","name":"Deployment of Wrong Handler"}],"description":"Deployment of wrong handler vulnerability in Apache HTTP Server allows the target of some internal redirects from CGI programs to also be treated as CGI and executed. The target must already be in a directory enabled for CGI and have no other extension understood by mod_mime.\n\nThis issue affects Apache HTTP Server: from 2.4.60 through 2.4.68.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache HTTP Server: limited RCE for some internal redirects to non-CGI files in CGI directories","id":"CVE-2026-42356","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:http_server","products":["apache:http_server"],"type":"code_injection","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Apache DolphinScheduler: Incorrect Authorization vulnerability allows users to access workflow instance information belonging to projects they do not have permission to access.","id":"CVE-2026-42357"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.69"],"introduced":["2.4.0"],"last_affected":[],"package":"apache","purl":"pkg:bitnami/apache","source":"BIT-apache-2026-42356"}],"prev":{"headline":"NanaZip: Uncontrolled recursion in NanaZip Electron ASAR parser causes stack exhaustion","id":"CVE-2026-42355"},"products":["Apache HTTP Server"],"published":"2026-10-01","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-01","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary code via internal redirects to non-CGI files in CGI-enabled directories due to incorrect handler deployment.","url":"https://insights.sbomify.com/CVE-2026-42356/"}